Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Image not shown on pages and in administraton


Go to End
Reply


18 Posts   6974 Views

Avatar
Sirius

Community Member, 7 Posts

14 August 2008 at 11:23pm

Edited: 18/08/2008 5:37am

Hi,

Please help me out with this problem:

Problem#1:
When I upload images from the administration-module, I can't see the image thumbnails.

Problem#2:
The image is not show om a page.

File permissions:
/assets/ - 777
/assets/Uploads/ - 777

File permission 644 and 777 do not help out the problem.

When I select an image from the image chooser (Uploads directory) and press the insert image button it shows the image in the wysiwyg-editor.

Avatar
UncleCheese

Forum Moderator, 4093 Posts

15 August 2008 at 8:17am

View the page source, find the image that it's looking for, and put that in your address bar. If you still can't see it, you know it has to be at the filesystem level.

Avatar
Hamish

Community Member, 712 Posts

15 August 2008 at 9:09am

Sirius, are you sure the GD2 extension for PHP enabled?

If you seem to be able to upload images, but the thumbnails and resampled images don't show up, that indicates to me that the image formatting bits are not working correctly. Also, have you made any changes to the default .htaccess file?

Cheers

Avatar
Sirius

Community Member, 7 Posts

15 August 2008 at 7:52pm

Edited: 15/08/2008 10:39pm

Hi again,

As you suggested, I tried to paste the image-url from the source kode into the adress in my browser and the and i still can't se it.

Avatar
Sirius

Community Member, 7 Posts

15 August 2008 at 10:39pm

My .htassess:

----------
### SILVERSTRIPE START ###
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###

----------

Avatar
UncleCheese

Forum Moderator, 4093 Posts

16 August 2008 at 1:23am

Can you go in your filesystem and find the file that it's looking for?

Avatar
Sirius

Community Member, 7 Posts

16 August 2008 at 1:26am

I have tried that. It dosen't work.

Avatar
pac

Community Member, 25 Posts

17 August 2008 at 9:52pm

could be a permission issue on _resampled and its content. try setting them to 755 rather than 644 or 777. Solved my problem but I have to do it manually for every new gallery. Not great I know, next I'll try to figure out where the permissions are set in the mkdir script...

Go to Top