Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

help installing SS.. error in rewritetest.php


Reply


6 Posts   1932 Views

Avatar
zakirs

Community Member, 3 Posts

17 August 2008 at 10:05pm

hi my installer showed everything was fine in install page and when iam going ahead with install it givs the following error ... iam testing SS on my own ubuntu , apache 2

Warning: file_get_contents(http://localhost/ss/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /var/www/ss/rewritetest.php on line 47

Warning: file_get_contents(http://localhost/ss/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /var/www/ss/rewritetest.php on line 47
mod_rewrite doesn't appear to be working. Make sure:
mod_rewrite is enabled in your httpd.conf
AllowOverride is enabled for the current path.
Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway.

Avatar
pac

Community Member, 25 Posts

18 August 2008 at 5:41am

pretty much self explanatory :
check that apache is compiled with mod_rewrite.
and check your hhtpd.conf for AllowOverride on that virtual server.

Avatar
zakirs

Community Member, 3 Posts

18 August 2008 at 5:58am

sry for being dumb ... :( iam noob .. well i have enabled mod_rewrite and can u explain the httpd.conf thing more please

Avatar
pac

Community Member, 25 Posts

18 August 2008 at 6:21am

hum...enabling mod_rewrite is not just one click away, you are getting me worried, my friend.

post a file info.php on you server with just these lines :

<?
phpinfo();
?>

run it, it will tell you a lot about what's really happening on your server. and where things are... for more info on httpd.conf, google shall be your new friend :)

Avatar
zakirs

Community Member, 3 Posts

19 August 2008 at 7:06pm

well i enabled mod rewrite but still the error is coming ... in the start page it says rewrite is enabled ( well i had to fight for 12 hrs to enable that ) :P ... se noobs have difficult lives :(

Avatar
Hamish

Community Member, 712 Posts

19 August 2008 at 7:48pm

Double check that you've followed all the instructions under HTTP Server on the installation wiki:

[url]http://doc.silverstripe.com/doku.php?id=server-requirements[/url]

Specifically, that you've configured apache.cnf with the following lines:

<Directory "/location/of/silverstripe">
Options FollowSymLinks SymLinksifOwnerMatch
AllowOverride All
Order allow,deny
Allow from all
</Directory>