Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

install issues


Go to End
Reply


10 Posts   2612 Views

Avatar
scorche

Community Member, 8 Posts

25 August 2008 at 4:57pm

I've got a problem that I keep having.
I annot log into my account, because I keep going back to the login page. It seems that this is a caching issue, as by the time it goes to the next page, it forgets who I am. This is not a browser issue though. I've had the same thing happen a few months back when I tried to install sNews. I eventually gave up and now I find myslf in the same problem.

I installed SS in a separate folder, I thought that I would have to specify where it was, but it seems that the install already takes care of the .htaccess ( although not having to put / at the end would be nice too).

I'm running PHP 5
Almost certain that it is an appache server, but I can't seem to figure out what it is
I also have wordpress running on root and am wonderig if that could be interfereing

any ideas ?

Avatar
Willr

Forum Moderator, 5513 Posts

25 August 2008 at 5:03pm

Is there a member created in the database? If you are using WAMP or MAMP or some server with phpmyadmin installed view your SS database and browse the members table and see if there is any records in there.

Other thing you can do is to hard code a member via the code. You can add this to your mysite/_config.php file - Security::setDefaultAdmin("user", "superCoolPassword"); which will create you a super user account which you can login and manage the users etc

Avatar
scorche

Community Member, 8 Posts

25 August 2008 at 5:22pm

thanks for the speedy reply

the Member:admin did get created

and adding my superuser did not help, it still keeps refreshing the same login site

Avatar
scorche

Community Member, 8 Posts

25 August 2008 at 5:26pm

does it make any difference if I chmod the directory from 755 to 775 (or 777)

Avatar
Willr

Forum Moderator, 5513 Posts

25 August 2008 at 5:26pm

Edited: 25/08/2008 5:31pm

did you install with the BlackCandy option? Security::setDefaultAdmin should work.

Otherthing you can do is to remove the admin member from the database (delete row) then run yoursite.com/db/build?username=admin&password=password to recreate the user

Avatar
scorche

Community Member, 8 Posts

25 August 2008 at 5:32pm

Edited: 25/08/2008 5:33pm

yes, it was blackcandy.
do you know where I should be looking for the php error log?

and I can't do install again because it says:
The server encountered an unexpected condition which prevented it from fulfilling the request.
The script had an error or it did not produce any output. If there was an error, you should be able to see it in the error log.

Avatar
scorche

Community Member, 8 Posts

25 August 2008 at 5:41pm

maybe this could help ?
http://daspoda.com/silverstripe/info.php

Avatar
scorche

Community Member, 8 Posts

25 August 2008 at 5:45pm

the NumVisit is incremented every time I try to log in.

I've tried removing the yoursite.com/db/build?username=admin&password=password before, but it didn't help

Go to Top