Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

New install, getting a list of iles instead of SS


Reply


7 Posts   1858 Views

Avatar
PatDeLux

Community Member, 4 Posts

30 August 2008 at 12:14am

Edited: 30/08/2008 8:18am

Hi all,
I am totally new here. I made a successfull install of SS in a ../silverstripe folder on my site.
When I http to mysite.com/silverstripe, I get a list of files.

However, if I go to mysite.com/silverstripe/anytext then I site the default site with a "page not found" page. From them I can navigate perfectly within the site.
If I navigate to mysite.com/silverstripe/admin, I get the admin page fine.

Is this a .htacces porblem ? A folder permission problem ?
Here is the content of the .htaccess file:

SetEnv REGISTER_GLOBALS 0
SetEnv ZEND_OPTIMIZER 1
SetEnv MAGIC_QUOTES 1
SetEnv PHP_VER 5
### SILVERSTRIPE START ###
<IfModule mod_dir.c>
DirectorySlash Off
</IfModule>

RewriteEngine On
RewriteBase /silverstripe

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###

Avatar
PatDeLux

Community Member, 4 Posts

7 September 2008 at 4:14am

I am really impressed by the number of answers ! What a vibrant community !

Avatar
grilldan

Community Member, 135 Posts

7 September 2008 at 5:30am

Insulting an entire community isn't how to go about asking for help.

However.

Try adding a slash to the end of your url.

yoursite.com/silverstripe/

Avatar
PatDeLux

Community Member, 4 Posts

7 September 2008 at 7:48am

Edited: 07/09/2008 8:03am

Thank you Grilldan.
This was definitely not an insult, just a comment.
Unfortunately, your answer does not reply to the question. I know how to reach the test site, and your suggestion takes me to the "Page not found" page.

I'd like SS to answer to the url www.idevlop.com/silverstripe (without slash) by providing the Home page, like anyone would expect.

After googling I tried adding

Options -Indexes

to the .htaccess.
This indeed prevents browsing, but by raising an Error 403 with the www.idevlop.com/silverstripe. Not ideal yet.

Any other idea/suggestion welcome !

Avatar
mihkel

Community Member, 2 Posts

7 September 2008 at 8:36am

Hello all,

same problem in here. I managed to solve it by changing DirectorySlash to On in .htaccess

Avatar
PatDeLux

Community Member, 4 Posts

7 September 2008 at 9:13am

Edited: 07/09/2008 9:23am

Problem solved.
1) I had changed the homepage url to "accueil" (same as home, in French) and I didn't know that keeping the homepage url to home was critical.
2) Following Mihkel's suggestion, I modified the part of .htaccess generated by Silverstripe installation, changing DirectorySlash from off to on.

Now it's ok.

Thanks.

Avatar
QualityKev

Community Member, 1 Post

12 September 2008 at 3:57am

I have the same question and am happy that changing this setting seems to resolve it. But I'm a bit reluctant to do this as presumably it has been set like this for a reason and I don't want to break anything. For those of us who have tried this change- have you noticed if anything else gets broken or is it all good news from now on?