Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Fatal Error when going to /admin


Reply


5 Posts   1329 Views

Avatar
Bietenfm

Community Member, 3 Posts

1 September 2008 at 8:19am

Hi,
I'm design a website with Silverstripe as CMS. But now i've got some problems.
When i went to /admin i get the following Fatal Error:

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 51896 bytes) in /storage/mijndomein/users/091374/public/sites/www.bouwbedrijflok.nl/sapphire/core/Requirements.php on line 220

But when i go to /admin/assets everything works fine but when i click on Content i get the again the Error.
The front-end site (http://www.bouwbedrijflok.nl/nieuwpage) works fine without problems, but with the Back-end i get the Errors.

I hope someone can help me.

Grtz,
Dennis

Avatar
Willr

Forum Moderator, 5513 Posts

1 September 2008 at 11:29am

that error is because your server does not have enough memory to process the page. Assets probably uses less memory then the main one.

See if you can up the php memory limit on your server - its set in the php.ini file on your server

Avatar
Bietenfm

Community Member, 3 Posts

2 September 2008 at 8:16am

Thanks for your answer.
I use a hosting provider. And the can't change the memory for me.
So is it possible to change max. use of the memory. So not everything will load.

Grtz,
Dennis

Avatar
Willr

Forum Moderator, 5513 Posts

2 September 2008 at 9:35am

No there is no way (well that doesnt involve rewriting a heap of code) to make the system use less memory. You could try overload your hosting providers settings by setting

ini_set("memory_limit", "64M");

at the top of sapphire/main.php

Avatar
Bietenfm

Community Member, 3 Posts

3 September 2008 at 6:22am

Thanks, but it didn't work.
I think i have to change from hosting provider. Or switch to an other CMS.

Thanks for your help.

Grtz,
Dennis