Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Publishing my website on the server??


Reply


17 Posts   38590 Views

Avatar
Pallas Athena

Community Member, 18 Posts

9 September 2008 at 8:54pm

Please, anyone...??? I would be ever so grateful for the help..

Avatar
Fuzz10

Community Member, 787 Posts

9 September 2008 at 10:27pm

Easiest way is to install phpmyadmin on your local and live webserver ... Then use that to export and import the mySQL dump ....

Avatar
Pallas Athena

Community Member, 18 Posts

9 September 2008 at 10:38pm

Thank you very much! I have the Wampserver with phpMyAdmin! Do you mean that it is so easy that I can use that to publish my site!?
Is there anything I should think about or is it just to follow the instructions for Export and do it the way I suspect it to be?

Avatar
Willr

Forum Moderator, 5513 Posts

9 September 2008 at 11:03pm

Ive written up a bunch of instructions on the wiki which covers publishing a site - http://doc.silverstripe.com/doku.php?id=publishing-to-web-server

Avatar
Pallas Athena

Community Member, 18 Posts

9 September 2008 at 11:36pm

Yes, thank you very much! I have tried that earlier, but I only get to step two, but when I try to go to the install-page I only get error.. So I can´t install it! :-(

Avatar
Fuzz10

Community Member, 787 Posts

10 September 2008 at 4:13am

First, focus on getting SS to run on your webhost ;-)

Avatar
Pallas Athena

Community Member, 18 Posts

10 September 2008 at 4:52am

I don´t understand! You mean the wampserver? ´Cause it´s already working, but then what? How do I publish it?

Avatar
Pixel

Community Member, 78 Posts

10 September 2008 at 5:10am

Edited: 10/09/2008 5:11am

If you have the files and .htaccess from the site you have built locally on your remote host you do not need to run the install, just make sure that the database is also up (done through your remote phpmyadmin) and that the database credentials match up to the mysite/config credentials.
Then run www.yoursite/db/build?flush=1