Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Argh! Help! Hack attack?


Reply

5 Posts   1764 Views

Avatar
KatB

9 September 2008 at 3:38pm Community Member, 94 Posts

OK, when attempting to call http://www.t-tec.com.au/ (a Silverstripe site) we are getting the message:

Fatal error: Allowed memory size of 18874368 bytes exhausted (tried to allocate 4864 bytes) in /home/ttec/public_html/sapphire/forms/CurrencyField.php on line 65

OK, what is going on? Is this an attempted hack gone wrong? It was most definately working previously ?

Avatar
KatB

9 September 2008 at 3:55pm Community Member, 94 Posts

I have attempted to copy over the forms directory with a local copy I have extracted. That does not seem to have helped.

This is a rather major drama for us, so although I would prefer to function with a cool head, I am not certain that a cool head prevails.

Logically, I can recreate nearly everything that was on the site, however, it would be rather handy if it could just be magically solved. I have made some customisations to Silverstripe (extra page types), nothing that would have caused this however.

Should I re-install a newer SIlverstripe version on top?

Avatar
KatB

9 September 2008 at 3:58pm (Last edited: 9 September 2008 4:11pm), Community Member, 94 Posts

You know what? Having a look at that error, to me it looks as though the server guys have done something. I'm asking them!

Alright, apparently there was a midnight upgrade last night and it has caused all sorts of havoc.

Using the solution found here: http://www.silverstripe.com/site-builders-forum/flat/7569#post7573

It didn't work.

Avatar
StuM

9 September 2008 at 4:11pm (Last edited: 9 September 2008 4:11pm), Community Member, 56 Posts

Memory limit set to ~18MB by the looks, should be 32MB for SS - details and solution here:

http://doc.silverstripe.com/doku.php?id=server-requirements

Avatar
Sigurd

10 September 2008 at 11:43pm Forum Moderator, 628 Posts

Yeah this is nothing to do with a hack. As the error message you pasted states, and as StuM rightfully points out, the script has run out of memory, thanks to an overly restrictive/low limit being set.