Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Newbie error


Reply


8 Posts   11852 Views

Avatar
Ross.allen

Community Member, 5 Posts

19 September 2008 at 2:38pm

Hello all,
Thanks in advance for havening a look and if you can help, thanks even more!!!
I'm just new to using silver stripe and CMS in general.
I'm installing S S on an apache server running locally on my mac thats running Leopard.

So I'm trying to install SS and I have an error:
"User 'nobody' needs to be able to write to this file:
/Applications/xampp/xamppfiles/htdocs/silverstripe/.htaccess"

So I've tryed to trackdown the .htaccess file and change the permission in finder and through trying to browse to it using a web browser.

I bet its really simple but it escapes me and google and previous post haven't enlightened me with the answer.

Thanks
Ross.

p.s what is the standard method to change the sharing permission of files.

Avatar
wifiman

Community Member, 20 Posts

19 September 2008 at 5:13pm

Hi Ross,

The Unix command to change permissions is chmod. On the mac, you can do this from a Terminal window. On my 10.4 mac, you can find Terminal in Applications->Utilities->Terminal.

If you've never played with a Unix prompt before, it can be a frustrating experience. but it's not too bad. It's text based, with a prompt after a $ or perhaps other punctuation depending upon your settings. In any case, try typing:

chmod 644 /Applications/xampp/xamppfiles/htdocs/silverstripe/.htaccess

This is the normal way I'd expect the files' permissions to work. (Owner gets read/write, group and other get read-only). If this doesn't work, let me know what error you see after running that command.

Avatar
Ross.allen

Community Member, 5 Posts

19 September 2008 at 5:47pm

Edited: 19/09/2008 5:49pm

Hi Wifiman,
Thanks for the help.

I've tried changing the permission through terminal
What I get as a responce is this
$ chmod 644/application/xampp/xamppfiles/htdocs/silverstripe/.htaccess
usage:   chmod [-fhv] [-R [-H | -L | -P]] [-a | +a | =a [# [ n]]] mode|entry file ...
    chmod [-fhv] [-R [-H | -L | -P]] [-E | -C | -i | -I] file ...

and the install page that is locally hosted still displays the message "
"User 'nobody' needs to be able to write to this file:
/Applications/xampp/xamppfiles/htdocs/silverstripe/.htaccess"

I the refreashed the page and even tried restarting apache to see if that would make any difference.
any ideas?
Thanks in advance Ross

Avatar
FlorianH

Community Member, 33 Posts

20 September 2008 at 1:12am

Looks like you forgot a blank space between "644" and "/application/xampp/xamppfiles/htdocs/silverstripe/.htaccess".

Avatar
Ross.allen

Community Member, 5 Posts

20 September 2008 at 3:34pm

Thanks for the help Florian,

I still couldn't get the chmod to work. So what I did I downloaded Tinker tools www.bresink.com/osx/TinkerTool.htm
Tinker Tools allows you to see files like .htaccess that are other wise hidden on the mac.
and then i changed the permission using the info menu.
I have now hit another brick wall!!
I am getting the error:
"
Warning: fopen(/Applications/xampp/xamppfiles/htdocs/silverstripe/.htaccess) [function.fopen]: failed to open stream: Permission denied in /Applications/xampp/xamppfiles/htdocs/silverstripe/rewritetest.php on line 167

Warning: file_get_contents(http://localhost/silverstripe/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /Applications/xampp/xamppfiles/htdocs/silverstripe/rewritetest.php on line 47

Warning: fopen(/Applications/xampp/xamppfiles/htdocs/silverstripe/.htaccess) [function.fopen]: failed to open stream: Permission denied in /Applications/xampp/xamppfiles/htdocs/silverstripe/rewritetest.php on line 167

Warning: file_get_contents(http://localhost/silverstripe/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /Applications/xampp/xamppfiles/htdocs/silverstripe/rewritetest.php on line 47

Warning: fopen(/Applications/xampp/xamppfiles/htdocs/silverstripe/.htaccess) [function.fopen]: failed to open stream: Permission denied in /Applications/xampp/xamppfiles/htdocs/silverstripe/rewritetest.php on line 167
mod_rewrite doesn't appear to be working. Make sure:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway."

Any Ideas???
I have opened the httpd.conf file with text edit but i have no idea what I'm looking at/for?

Thanks in advance!

Ross

Avatar
bennybtl

Community Member, 12 Posts

21 September 2008 at 2:44am

Edited: 21/09/2008 2:49am

Ross,

The apache server that comes with osx is configured a bit weird it seems (for security) it makes setting up anything complex like SS a hassle. edit: I see you're using xampp, which I've never tried under osx...

I've found that using mamp [url]http://www.mamp.info/en/index.php[/url] works flawlessly. Give it a try?

Avatar
Ross.allen

Community Member, 5 Posts

21 September 2008 at 10:48am

Thanks Bennybtl.

I'll give it a try and see how I get on.

Avatar
Ross.allen

Community Member, 5 Posts

21 September 2008 at 1:36pm

Man I wished I had used Mamp to start with its sooooo much easier and straight forward. thanks again for all your help!!!
Ross.