Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

XML Parsing Error in FF


Reply


4 Posts   2691 Views

Avatar
Mishy

Community Member, 24 Posts

21 September 2008 at 5:36am

Edited: 21/09/2008 5:37am

XML Parsing Error: mismatched tag. Expected: </body>.
Location: http://www.search4pharma.co.uk/permanent/
Line Number 224, Column 3:</div>
--^


I have tried everything I can think of and checked the div tags over and over again and cannot figure out how to fix this.

On the pages where I use a page extension template I get an XML Parsing Error.

Where I don't extend the template and just use the Page.ss it works fine.

Anyone able to point me in the right direction please?

[url]http://www.search4pharma.co.uk[/url]

Avatar
Hamish

Community Member, 712 Posts

21 September 2008 at 8:36am

There is definitely and error in your template, I count two extra </div>'s. Want to post the template file?

Avatar
Mishy

Community Member, 24 Posts

21 September 2008 at 9:01am

It's really weird, with the original error that you mentioned yesterday, I couldn't see that the Page.ss was missing any div tags but when I added an extra div it fixed the home page error.

Trouble is, I am used to dealing with a single page of XHTML in it's entirety for each web page I want to create, not parts of pages brought together into one final page. This is probably where I am getting a bit mixed up. :-(

Avatar
Mishy

Community Member, 24 Posts

21 September 2008 at 9:19pm

A good night's sleep and fresh eyes and I have fixed the problem. Went through all the code and commented start and finish of each div. I picked up on a couple of errors and it all seems to be working well now :-)