Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

rewritetest error


Go to End
Reply


11 Posts   3540 Views

Avatar
raamklaza

Community Member, 182 Posts

29 September 2008 at 5:50am

Hello,

i installed silverstripe again but i get a rewritetest error all the time.

I deleted all the files and the db and did a fresh install but still the error.

Can someone help me out?

Warning: file_get_contents(http://localhost/1-Ontwikkeling/silverstripe-v2.2.2/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. in C:\wampserver\www\1-Ontwikkeling\silverstripe-v2.2.2\rewritetest.php on line 47

Fatal error: Maximum execution time of 30 seconds exceeded in C:\wampserver\www\1-Ontwikkeling\silverstripe-v2.2.2\rewritetest.php on line 47

Avatar
grilldan

Community Member, 135 Posts

29 September 2008 at 6:29am

You need to increase the max execution time. I'm assuming you are running this on localhost with wampserver.

Click the wampserver icon in your tray, go to the PHP folder, and click php.ini. Search that file for "Resource Limits" bellow there, you will have a few things you can change. Increase the max_execution_time from 30 to 300 (That should be good enough). Then restart wampserver.

Avatar
raamklaza

Community Member, 182 Posts

29 September 2008 at 6:58am

Oke thnx, that worked somehow. now i get the following error:

Warning: file_get_contents(http://localhost/1-Ontwikkeling/silverstripe-v2.2.2/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. in C:\wampserver\www\1-Ontwikkeling\silverstripe-v2.2.2\rewritetest.php on line 47

Warning: file_get_contents(http://localhost/1-Ontwikkeling/silverstripe-v2.2.2/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. in C:\wampserver\www\1-Ontwikkeling\silverstripe-v2.2.2\rewritetest.php on line 47
mod_rewrite doesn't appear to be working. Make sure:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway.

Avatar
grilldan

Community Member, 135 Posts

29 September 2008 at 7:50am

Did you allow mod_rewrite in your httpd.conf?

wampserver icon > appache > httpd.conf

search for "mod_rewrite" and make sure there isn't a "#" at the start of the line.

Avatar
raamklaza

Community Member, 182 Posts

29 September 2008 at 7:51am

nope, no # infront of it

LoadModule rewrite_module modules/mod_rewrite.so

Avatar
grilldan

Community Member, 135 Posts

29 September 2008 at 7:54am

Whats your .htaccess file look like?

C:\wampserver\www\1-Ontwikkeling\silverstripe-v2.2.2\.htaccess

Avatar
raamklaza

Community Member, 182 Posts

29 September 2008 at 7:57am

The following:

### SILVERSTRIPE START ###
RewriteEngine On
RewriteBase /1-Ontwikkeling/silverstripe-v2.2.2

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* C:/wampserver/www//sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###

Avatar
grilldan

Community Member, 135 Posts

29 September 2008 at 8:01am

Edited: 29/09/2008 8:03am

Try this...

### SILVERSTRIPE START ###
<IfModule mod_dir.c>
DirectorySlash Off
</IfModule>
RewriteEngine On
RewriteBase /1-Ontwikkeling/silverstripe-v2.2.2
RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$
RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###

**also**
go back to your httpd.conf file and search for "Options FileInfo AuthConfig Limit"
make sure it looks like:

AllowOverride all <-- correct

not

AllowOverride none <-- wrong

Go to Top