Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Mac OS X - multiupload??


Reply


8 Posts   2622 Views

Avatar
jacobsjensen

Community Member, 20 Posts

30 September 2008 at 8:01am

Hi there,
Is it only me, or do multiupload not work on a mac?

Avatar
Willr

Forum Moderator, 5513 Posts

30 September 2008 at 4:58pm

We all use OSX in the office and it seems to work fine. Are you using 2.2.1? This included a swfUploader which didnt work at all!

Are you using safari or firefox?

Avatar
jacobsjensen

Community Member, 20 Posts

30 September 2008 at 7:15pm

I'm on a fresh 2.2.2 install.

OS X 10.5.5

Firefox/3.0.3 = Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414

Safari 3.1.2 (5525.20.1)

Hope this is sufficient info :-)

Avatar
Willr

Forum Moderator, 5513 Posts

30 September 2008 at 9:08pm

Next Question heh :) - Are you trying to use the multiupload in the assets ('Files and Images') section? As a little test jump onto our demo site - demo.silverstripe.com/admin/assets and try then file multi uploader on that. It could be a permission error/ js error just trying to cut it down!

Avatar
jacobsjensen

Community Member, 20 Posts

30 September 2008 at 9:17pm

Edited: 30/09/2008 9:18pm

:-) Yep, that's the place.
I just logged in to the demo site, no luck there... I've tested it on 4 individual machines, but all running the same OS and browser versions.
P.S. selecting one file is no problem, and uploading it is no problem.

I can see that the demo is 2.2.1... as you mentioned before... maybe a buggy swfuploader...

Avatar
Willr

Forum Moderator, 5513 Posts

30 September 2008 at 9:30pm

Even though demo says 2.2.1 Im pretty sure someone upgraded that recently to 2.2.2.

Ok Im lost as on my 2 macs it works fine :) safari 3.1.2, OSX 10.5.5. Hmm if anyone can confirm the problem then you might like to make a ticket on open.silverstripe.com I wouldn't be worried if it was only on 1 computer but on all 4 is a bit odd. Do they run any addon's/ plugins that are the same that could be blocking it? Flash Disablers?

If you use firefox with Firebug enabled you should be able to see the 'Post' request to upload the files under the console part. Do any errors appear in there it does it seem to work fine?

Avatar
artlung

Community Member, 10 Posts

4 October 2008 at 6:54am

I can verify that in Safari 3.1.2 and Firefox 3.0.3 I am unable to select more than one file in the Finder dialog that comes up. Operating system version is MacOS X 10.4.11.

I think it's the operating system that's disallowing selecting more than one file -- though I wonder if there's a way to indicate to the OS to allow multiple files.

This is on the demo site and my installation of SilverStripe 2.2.2.

Avatar
Willr

Forum Moderator, 5513 Posts

4 October 2008 at 11:14am

artlug, you shouldnt be able to multiselect files in the finder window. You have to select them 1 by 1. You have to hit browse, select a file, Ok then hit browse again