Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Problem whit topic in forum


Reply


5 Posts   875 Views

Avatar
ojalà

Community Member, 87 Posts

2 October 2008 at 9:40pm

Hi!
I try to install forum e I do.
Default Silverstripe forum creates a "General discussion" but when I click over this to edit new topic I have an error:

Errore interpretazione XML: contenuto illegale dopo l'elemento
Indirizzo: http://mysite/general-discussion/
Linea numero 2, colonna 1:<b>Notice</b>: Controller::currentController() is deprecated. Use Controller::curr() instead. in <b>E:\_silverstripe_cms\elisa\sapphire\core\control\Controller.php</b> on line <b>367</b><br />
^

I'm unable to resolve this problem. I red an other topic in this forum similar to my problem but I dont solve this problem

Avatar
Willr

Forum Moderator, 5513 Posts

2 October 2008 at 9:56pm

The stable version of the forum is quite old and will not work with 2.2.2. We are currently planning on releasing a new version within a few weeks. At this stage I suggest you download the latest daily build - http://dailybuilds.silverstripe.com/modules-tarballs/

Avatar
ojalà

Community Member, 87 Posts

2 October 2008 at 10:11pm

Thanks!
To install the new version what Can I do?
1. replace the old directory forum in the root whit the new? (copy/past)
2. db/build?

If I do this Have I problem with table in the database?

(I ask this because when replace the gallery directory I had problem in the db end I can't enter in http://mysite/admin..)

Avatar
Willr

Forum Moderator, 5513 Posts

2 October 2008 at 10:16pm

if you havent used the forum best way is to delete the old forum/. paste in the new one. then rebuild the db and see if that works

Avatar
ojalà

Community Member, 87 Posts

2 October 2008 at 10:27pm

Thanks!
I solve everything!! :)