Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Permissions problem with Assets


Go to End
Reply


15 Posts   4439 Views

Avatar
Macello

Community Member, 37 Posts

16 October 2008 at 8:07pm

Hello there, i got a problem with the
permissions of the upload function in Silverstripe. for all files that have been uploaded by Silverstripe (with the CMS upload and form uploads in frontend, the files are always only read and execute for the owner (server) so i always need to make them manually write and read for others, otherwise not even out of the cms you can read them.
How can i solve this problem? i can't say to the client he has to do this manually in the webftp.

Greetz and thanks already, Silverstripers

Avatar
Macello

Community Member, 37 Posts

16 October 2008 at 11:07pm

any solutions on this?

Avatar
Double-A-Ron

Community Member, 604 Posts

17 October 2008 at 12:14am

This doesn't sound right. Have you ever had similar issues when uploading a file on this server using a plain php script? (e.g. a server issue)

Every installation of SS that I've tried makes the uploaded files 644 - read/write owner, read group, read everyone.

Cheers
Aaron

Avatar
Macello

Community Member, 37 Posts

17 October 2008 at 12:25am

yes i had the same problem on another server too... is there a list of all the permissions to set on folders and files, would like to control that. in MAMP i never had that problem.

Avatar
Double-A-Ron

Community Member, 604 Posts

17 October 2008 at 12:38am

.htaccess file writeable?   
mysite/ folder writeable?   
tutorial/ folder writeable?   
assets/ folder writeable?   
temporary folder writeable?

So all of those 755

Cheers
Aaron

Avatar
Macello

Community Member, 37 Posts

17 October 2008 at 12:45am

inlcuding the files in these folders or just the folders?

Avatar
vstrazz

Community Member, 63 Posts

17 October 2008 at 8:37am

I've noticed when moving a my current production level silverstripe files on the server to the staging domain, the assets folder needs to have the permissions re set to 777 or I will have problems like the ones you are seeing.

Good Luck.

Avatar
Macello

Community Member, 37 Posts

18 October 2008 at 2:50am

The Problem Still exists, after uploading the files are write and read for user. and by uploading i get this (i tried 3 of five possibles):

XML-Verarbeitungsfehler: "Junk" nach Dokument-Element
Adresse: http://swissfinancescout.ch/finanzierungsantrag/?executeForm=Form
Zeile Nr. 2, Spalte 1:<b>Notice</b>: Array to string conversion in <b>/srv/www/htdocs/web83/html/sapphire/core/model/DataObject.php</b> on line <b>570</b><br />
^

Need Help for That, website should be on already!

Go to Top