Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

The website server has not been able to respond to your request


Reply

6 Posts   4339 Views

Avatar
Tareq

20 October 2008 at 10:53pm (Last edited: 21 October 2008 12:10am), Community Member, 8 Posts

hi
i m trying to attach images on Admin side , but when i m adding image so its giving me error

"The website server has not been able to respond to your request".

i m using Linux server to up my side.
server have write permissions to the "assets/Uploads/" Folder.
not able to save images :(

if any body face this problem on admin side plz suggest me if i m doing any mistake.

But its working smoothly on local side.

thanx
tareq

Avatar
Willr

22 October 2008 at 10:30pm Forum Moderator, 5511 Posts

Try turning on errors by setting the site in dev mode - Director::set_environment_type("dev"); in your mysite/_config.php . This will output the actual error

Avatar
Tareq

22 October 2008 at 11:31pm (Last edited: 22 October 2008 11:32pm), Community Member, 8 Posts

Thanx for your advice.

but i m not able to see my images on Admin side after attaching images to it.
on server itself.
plz suggest me something.

thanx
tareq

Avatar
Willr

22 October 2008 at 11:40pm Forum Moderator, 5511 Posts

I would just make sure that all the assets are read / writable.. also if you have safe mode turned on in your php.ini it can interfere with the uploader. Im not sure what else you can look for :( maybe your php file limit size is set to low in your php.ini file? this would normally throw an error though.

Avatar
Tareq

22 October 2008 at 11:57pm Community Member, 8 Posts

Hi Willr,

Thanx & appriciating for your help.
i have checked with all the settings what ever you have told.

assets -> read / write permissions are on
php.ini
safe mode = off
upload_max_filesize = 32M

i m using Linux server .

its still working on my local machine but not working with server :(

thanx
tareq

Avatar
Stefan

8 November 2008 at 1:18am Community Member, 5 Posts

I had the same issue. Enabled dev with: Director::set_environment_type("dev"); in _config.php

This gave me the error:

FATAL ERROR: copy(/home/webdev/public_html/assets/Uploads/footerbg.gif) [function.copy]: failed to open stream: Permission denied

At line 229 in /home/webdev/public_html/sapphire/filesystem/Folder.php

Set global permissions to writeable recursively on the uploads folder. Issue resolved.

Hope this helps.