Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Re-install failing at Building database schema...


Reply


8 Posts   1664 Views

Avatar
mschiefmaker

Community Member, 187 Posts

28 October 2008 at 2:52pm

Having started work with SS on one site last week and being very happy with the solution I thought I'd move another one to it this morning. I completed the install successfully but then after a series of problems (caused by an error on my part) I decided to deinstall, drop the database and start again. Simple I thought but now the install is freezing at
Building database schema...

I have read through the other entries with this problem but none seem to apply. Could anything be hanging around from the original install that might be causing this problem?

Thanks

MM

Avatar
Willr

Forum Moderator, 5513 Posts

28 October 2008 at 8:56pm

Even if it just hangs can you try view the site? does the install work or does it redirect you back to the install screen?

Avatar
mschiefmaker

Community Member, 187 Posts

28 October 2008 at 10:24pm

Hey Will
No the install doesn't appear to complete. There are no database tables installed and I get a 404 error in IE and a blank screen in Firefox when I try to access the admin even after flushing the database

When I do the instal I see
If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating /var/www/html/silverstripe/mysite/_config.php
# Creating '.htaccess' file...
# Creating /var/www/html/silverstripe/.htaccess
# Building database schema...

and then it just hangs.

I have tried manually placing the .htaccess file ... a suggestion from an earlier TAR.

I have tried uninstalling everything again and starting from scratch but it doesn't help. I notice I can't delete the tews directory though it is empty. I am not sure what this does so it may not be relevant.

I can't help wonderng if the problem is with the fact I dropped the database.

Any other thoughts

Cheers

MM

Avatar
mschiefmaker

Community Member, 187 Posts

28 October 2008 at 11:53pm

By putting some echos in the install.php file I can see that it fails at the line

ManifestBuilder::compileManifest();

Is there a way to switch on more error message so I can see whats going on?

MM

Avatar
mschiefmaker

Community Member, 187 Posts

29 October 2008 at 11:09am

The error occurs in ManifestBuilder when tries to DB::connect($databaseConfig);

Why would this fail?

mm

Avatar
Willr

Forum Moderator, 5513 Posts

29 October 2008 at 11:51am

is $databaseConfig set / correct? eg can you do a Debug::show($databaseConfig); on the line before it dies and see if thats set

Avatar
mschiefmaker

Community Member, 187 Posts

29 October 2008 at 12:25pm

Hi Will
I get nothing returned by Debug::show($databaseConfig); but if I do a print_r I get

Array ( [server] => localhost [username] => exclusiveesc [password] => ****** [database] => exclusiveescape_com_-_cms )

I have checked all the permissions and they seem fine. Any other thoughts?

MM

Avatar
mschiefmaker

Community Member, 187 Posts

29 October 2008 at 4:43pm

Not sure if you would say I have fixed the problem but I am now on a complete install - yay.

I did another reinstall but this time I forced the deinstall of the tews directory.

The problem appeared to be accessing any files in the sapphire directory but I never managed to figure out what... oh well it is just great to be able to get on with it.

Thanks for your help Will

MM