Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Install parse error


Reply


3 Posts   1382 Views

Avatar
Nuttydo

Community Member, 16 Posts

8 November 2008 at 7:21am

Tried to install.

Up to install.php, all okay, file permissions okay, PHP config items okay.

But there was a warning:
Webserver Configuration
Server software - I can't tell what webserver you are running. Without Apache I can't tell if mod_rewrite is enabled.
mod_rewrite enabled - I can't tell whether mod_rewrite is running. You may need to configure a rewriting rule yourself.

The warning said I could install anyway, so clicked okay. Next screen took me through install and then directed to site/home/successfullyinstalled?flush=1 ("site" is the directory SS is in but there doesn't seem to be a "home" folder anywhere??!) and the following error message:

Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/0/d68570838/htdocs/sprachlernstrategien/site/sapphire/core/ManifestBuilder.php on line 35

Can't get any further. By the way, db68570838 is the name of the database that exists already on the webserver (not the default ss_mysite). Is this wrong?

Also, in order to start again, I have to delete and upload the whole CMS or else I get a similar error message.

Can anyone help? I am desperate, here. And probably have made some idiot of a mistake because this is all new territory to me.

Avatar
runnerman

Community Member, 24 Posts

9 November 2008 at 1:34am

Edited: 09/11/2008 1:38am

On a shared server there are sometimes issues when silverstripe tries writing to the /tmp folder which is usually shared and not accessible to individual users.

Try creating a folder called silverstripe-cache in your main silverstripe folder and doing a fresh install. Silverstripe will then use the silverstripe-cache folder instead of /tmp as it's cache location. (see [url]http://www.silverstripe.com/site-builders-forum/flat/4873[/url] for some detail.)

Avatar
Nuttydo

Community Member, 16 Posts

9 November 2008 at 3:10am

Edited: 09/11/2008 3:41am

Thanks runnerman for the help and thanks for taking the time out to help me. Unfortunately it didn't work. I even set up a new database on my girlfriend's site (she doesn't use it) so if there are any entries on it then they are the only ones. I re-uploaded the silvertstripe files, inserted the htacess file to point to php5, created a folder called silverstripe-cache and then opened the install page.

Same message as before, went ahead and clicked install, it went through the motions and then it brought me to the rewritetest.php page and I got this message (same as last time):

mod_rewrite doesn't appear to be working. Make sure:
mod_rewrite is enabled in your httpd.conf
AllowOverride is enabled for the current path.
Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway.

Click and up pops a message saying "forced continue, attempting to redirect to home/successfullyinstalled" where home/successfullyinstalled is a link and then it takes me to said successfullyinstalled file and the same message as in my original post about the ManifestBuilder.

I've been playing around with Silverstripe for a few months now, first got it to work on my PC and now determined to get it to work on a server. It should work. I can't believe there's something wrong with my server or provider, they are a well-established company. It's got to be me. What am I doing wrong?

Just to check: the silverstripe-cache folder was created in the folder (I named this folder CMS) where the other parts of Silverstripe are found (assets, cms, sapphire, etc). The folder containing all of Silverstripe is two levels down from the "/" level of my webspace. Could this also be an issue?

Update: Spoke to my service provider and they say it probably is down to the php.ini. I need to create a php.ini file and put in the correct parameters to tell the server I am allowed to write. Is this good advice and how do I do it?