Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

tinymce not working for blog module?


Reply

6 Posts   1061 Views

Avatar
raamklaza

9 November 2008 at 4:46am Community Member, 182 Posts

Tinymce options aren't working in the blog module.

Anyone has the same?

Anyone know how to fix it?

Avatar
Liam

9 November 2008 at 6:53am Community Member, 470 Posts

Make sure you're using a daily build/svn copy of the blog module. Then you can add this line to your config file BlogEntry::allow_wysiwyg_editing();

Or open up and edit blog/code/BlogEntry.php and you can change the variable from false to true. (static $allow_wysiwyg_editing = true;)

Adding it to the config probably a better idea, as it makes upgrading smoother.

Avatar
raamklaza

11 November 2008 at 10:56am Community Member, 182 Posts

I put you suggestion in the _config.php file in sapphire, but it gives me the following:

f�
Fatal error: Call to undefined method BlogEntry::allow_wysiwyg_editing() in C:\wampserver\www\1-Ontwikkeling\silverstripe-v2.2.2\sapphire\_config.php on line 71

Where do i get the latest build? i search through trac but i can't really find it.

Avatar
Liam

11 November 2008 at 11:14am (Last edited: 11 November 2008 11:14am), Community Member, 470 Posts

http://doc.silverstripe.com/doku.php?id=daily-builds

That setting might only work in 2.3. I can't remember to be honest. So if it doesn't work after you use the latest build, just edit the line in the BlogyEntry.php file.

Avatar
raamklaza

11 November 2008 at 12:35pm Community Member, 182 Posts

I changed the link in the BlogEntry file and did a db/build but the wysiwig is not working.

The allow_wysiwig_editing string wasn't in their yet so i put it in.

Does the place mather?

<?

class BlogEntry extends Page {
   
   static $default_parent = array('BlogHolder');
   
   static $can_be_root = false;
   
      static $icon = "blog/images/blogpage";
   
   static $db = array(
      "Date" => "Datetime",
      "Author" => "Text",
      "Tags" => "Text"
   );
   
   static $allow_wysiwyg_editing = true;
   
   static $casting = array(
      "Date" => "Date"
   );
   
   static $defaults = array(
      "ProvideComments" => true
   );

Avatar
Liam

11 November 2008 at 2:40pm Community Member, 470 Posts

Make sure you're using the newest one (or at least one of the newest ones). If you downloaded it and the line wasn't there, you're probably using an older version.

As of today, this is the latest one which has it in there - http://dailybuilds.silverstripe.com/modules-tarballs/blog.2008-11-11.tar.gz