Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

ERROR: The website server has not been able to respond to your request.


Reply


2 Posts   1317 Views

Avatar
D.K.

Community Member, 20 Posts

19 November 2008 at 4:15am

I am attempting to install SilverStripe on to my Dreamhost server. The installation runs, I enter everything necessary, it checks database requirements, then I click Install. An new page shows up, shows steps of installation, and right after "Building database schema" I get a SilverStripe logo and the message: The website server has not been able to respond to your request. When I turn on 'dev' mode, I see that it is attempting to access portools.Page, and portools.Table, and such (portools is my database name), but they do not exist. Isn't the installer supposed to create them? Am I doing something wrong?

Thank you in advance!

P.S. I've tried this on the most recent version, and on the trunk version.

Avatar
D.K.

Community Member, 20 Posts

19 November 2008 at 6:07am

I've tried rebuilding the database. In the verbose output, it creates a few tables, then tries to show full fields for table Permission which was never created. Here's the error:

[User Error] Couldn't run query: SHOW FULL FIELDS IN `Permission` Table 'portools.Permission' doesn't exist
GET /db/build?flush=1

What's wrong?