Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

SideBar images


Reply

13 Posts   2602 Views

Avatar
mhull

24 November 2008 at 3:37am Community Member, 79 Posts

What I am seeing on the page in the sidebar is the code, for example in the sidebar I put an image and text, and it is showing the code but not the image:

<img src="http://localhost:8888/silverstripe/assets/Home/_resampled/StripThumbnail-home.jpg" title="home.jpg" alt="home.jpg" class="destwidth=" />

If I look at the source of the page it shows the tags are not rendering properly:
&lt;img src="http://localhost:8888/silverstripe/assets/Home/_resampled/StripThumbnail-home.jpg" title="home.jpg" alt="home.jpg" class="destwidth=" /&gt;

Is there something I need to change in the TinyMCE? if so what would it be?

Avatar
mhull

24 November 2008 at 5:33am Community Member, 79 Posts

Can anyone help with this html problem? is it to do with TinyMCE? What do I need to change?

Avatar
mhull

24 November 2008 at 9:08am Community Member, 79 Posts

Is this something to do with the HTMLEditorField.php?

Avatar
mhull

24 November 2008 at 11:05am Community Member, 79 Posts

Can anyone offer any advise? I still haven't managed to get the problem solved

Avatar
jam13

24 November 2008 at 11:54am 121 Posts

That output looks like it's being xml escaped. You mentioned that you were using $Sidebarcontent.XML before so it's possible that the template is still cached, so try flushing the page.

If it's not that, then I have no idea.