Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Installation issue


Reply


6 Posts   2945 Views

Avatar
Luca

Community Member, 8 Posts

25 November 2008 at 5:27am

Hi boys,

I have a problem to install SS on my virtual server.
I have alredy post some question about this in another topic.
My server is an image of ubuntu 6.0.6.1, virtualized by vmware. In this server i install php5 and apache2 (with mod_rewrite).

I download from this site SS cms install package, i gunzip and xtar this. I point with my browser index.php ant try to install, but SS tell me that the mod_rewrite not work propertly and after this it redirect browser to the <ipaddress>/myfolder/InstallTest/testrewrite that not exists on my server.

Please help me, where is the problem? I follow all the instruction...

Probably in a newby question, but i can't find any solution.

I attach to this post, my php info file, the apache configuration file and the page where i see the error.

Thanks thanks thanks in advance.
Luca.

Avatar
Luca

Community Member, 8 Posts

25 November 2008 at 6:21am

In add i paste the error that the SS installation give me:

Checking mod_rewrite workshttp://spartaserver/silverstripe-v2.2.3/InstallerTest/testrewrite Rewrite is DirectorySlash Off RewriteEngine On RewriteBase /silverstripe-v2.2.3 RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$ RewriteCond %{REQUEST_URI} ^(.*)$ RewriteCond %{REQUEST_FILENAME} !-f RewriteRule .* /var/www/sapphire/main.php?url=%1&%{QUERY_STRING} [L]
Creating /var/www/silverstripe-v2.2.3/.htaccess http://spartaserver/silverstripe-v2.2.3/InstallerTest/testrewrite
ERROR: mod_rewrite not working, redirecting to mod_rewrite test page
Creating /var/www/silverstripe-v2.2.3/.htaccess I will now try and direct you to rewritetest to troubleshoot mod_rewrite

Thanks!
Luca

Avatar
Luca

Community Member, 8 Posts

25 November 2008 at 10:23am

Sorry if i post every hour...
I think that my problem is in apache2 configuration, in fact i am a very newby in apache2.

As you can see in my phpinfo file, mod_rewrite is correctly loaded, so i think that is incorrectly configured. (I must think this).

What i must do? I try all possibility!

The last one is this:
########################## DEFAULT
NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# Uncomment this directive is you want to see apache2's
# default start page (in /apache2-default) when you go to /
#RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>
<IfModule mod_rewrite.c>
RewriteEngine On
</IfModule>
</VirtualHost>

################################### SILVERSITE (The second)
<VirtualHost *>
<Directory /var/www/silverstripe/>
Options FollowSymLinks SymLinksifOwnerMatch
AllowOverride All
Order allow,deny
Allow from all
RewriteEngine On
RewriteBase /
</Directory>
<IfModule mod_rewrite.c>
RewriteEngine On
</IfModule>
</VirtualHost>

And in my /var/www:
root@ubuntu:/var/www# more .htaccess
AllowOverride All
RewriteEngine On
RewriteBase \

Avatar
Luca

Community Member, 8 Posts

25 November 2008 at 11:17am

Another issue is this, when i try to run [ php rewritetest.php] i got this error:

Warning: file_get_contents(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /works/sites/silverstripe/rewritetest.php on line 47

Warning: file_get_contents(http://./InstallerTest/testrewrite): failed to open stream: Success in /works/sites/silverstripe/rewritetest.php on line 47

Warning: file_get_contents(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /works/sites/silverstripe/rewritetest.php on line 47

Warning: file_get_contents(http://./InstallerTest/testrewrite): failed to open stream: Success in /works/sites/silverstripe/rewritetest.php on line 47
mod_rewrite doesn't appear to be working. Make sure:<ul><li>mod_rewrite is enabled in your httpd.conf</li><li>AllowOverride is enabled for the current path.</li></ul>Please check these options, then refresh this page.If you believe that your configuration is correct, <a href="rewritetest.php?force=1">click here to proceed anyway.</a>root@ubuntu:/works/sites/silverstripe

I have a terrible headache.... Is possible that install SS is impossible for me?

Avatar
Sam

Administrator, 685 Posts

28 November 2008 at 10:46am

The problem is in your apache config.

In the section "<Directory /var/www/>"

Change this:
AllowOverride None

To this:
AllowOverride All

Avatar
dixid

Community Member, 1 Post

14 December 2008 at 12:29am

Hello,
I've the same Problem: Warning: file_get_contents...

But I can't change the Apache Config because it isn't my own server.
Now I can't use SilverStripe???

dixid