Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

[SOLVED] 2.3.0 RC2 .htaccess - DirectorySlash and RewriteBase


Reply


7 Posts   4319 Views

Avatar
Double-A-Ron

Community Member, 604 Posts

8 December 2008 at 3:15pm

Edited: 11/12/2008 3:55pm

Hi There,

I have downloaded 2.3.0 RC2 for testing and tried installing on Webdrive. 2.2.3 installs just fine.

With 2.3.0, I immediately got a 500 error. So I started commenting out lines of the .htaccess file until I found the culprit was

DirectorySlash Off

So I comment this out and leave everything else as per the original

This results in a 404 error as follows:

The requested URL /httpd/vhlinks/mysite.co.nz/sapphire/main.php was not found on this server.

I think there should be "/home" at the front of that path.

Anyway, I go back to a 2.2.2 site that I have functioning on this same server and directly copy it to the 2.3.0 test directory.

Now when I refresh, the site is re-directed to http://www.install.php, which obviously isn't right.

Any ideas on this? How is 2.3.0's redirecting different to that of 2.2.x? And would this be indicative of the problems I will expect when using future releases of 2.3.x onwards on this host?

Regards
Aaron

Avatar
JGC

Community Member, 25 Posts

8 December 2008 at 10:08pm

I had the same problem when installing SS to ASmallOrange.

You have to take out the DirectorySlash rule several times as it keeps putting it back in.

Take it out, run the install script, when that dies go to site.com/dev/build?flush=1, then go back and take DSlash out again. I ended up having to upload my mysite/_config.php a few times before it stuck, but it will get to a fully installed and working state, just gotta give it a bit of a kick :)

Avatar
Double-A-Ron

Community Member, 604 Posts

11 December 2008 at 3:55pm

And ofcourse you are correct.

The installer had uncommented the DirectorySlash line again. Re-Commenting it and the site works fine.

Thanks for the heads up.
Aaron

Avatar
cheekygeek

Community Member, 6 Posts

12 December 2008 at 7:16am

I'm a SS newbie (and worse, trying to install on 2000 Server IIS 5). But if there is a difference between rewrite stuff from 2.2 to 2.3, then it may explain a problem that I'm having:

I've got PHP5 installed (ISAPI) along with the latest MySQL 5.1 and Helicon's ISAPI Rewrite 3. Helicon has specific instructions for SilverStripe (which is nice) except that they are for version 2.2.2.

I've got SilverStripe 2.3.0 rc2 installing properly (not in the root folder, but in the subdirectory "intranet"), except at the end it says mod_rewrite is working and then tries to redirect to http://www.mydomain.com/intranet/home/successfullyinstalled?flush=1

This results in a 404 error. There is no "home" directory in the intranet directory. So where is this "home" coming from, and how do I diagnose the problem from here?

I see no DirectorySlash in my root htaccess file. I've tried RewriteBase with both /intranet and intranet. No joy.

Avatar
Double-A-Ron

Community Member, 604 Posts

12 December 2008 at 9:30am

Hi Ya,

Have you tried navigating to the root of your new site?

e.g. http://www.mydomain.com/intranet/

Installs often appear to fail for me except on WAMP. Ever since 2.1. But more often than not, even though it can't complete the installation proccess all the way through, it was still installed.

Cheers
Aaron

Avatar
cheekygeek

Community Member, 6 Posts

12 December 2008 at 10:41am

Thanks for the reply. When I try the root of the site it redirects to the install page (telling me it looks like it is already installed and offering to overwrite .htaccess and _config.php). If I rename the install.php it still tries to redirect there. What URL should I be calling to try to get a page?

As a noob, I'm a little confused. Does SilverStripe have to be installed in the web root or can you have static pages in the web root and install SilverStripe in a subdirectory? Obviously, the .htaccess is only written in the subdirectory.

Avatar
Double-A-Ron

Community Member, 604 Posts

12 December 2008 at 10:48am

No I've had it installed in a subdirectory before. There is something else going on here.

Remember you are using a release candidate there though. Not really ready for production and last I looked there were over 100 bugs in Trac for this version.

I say try removing 2.3.0 RC2 and installing 2.2.3 stable.

Cheers
Aaron