Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Database corrupt!


Reply


4 Posts   1773 Views

Avatar
poblom

Community Member, 25 Posts

13 December 2008 at 11:05am

Our site has been running live now for a couple of month. Suddenly tonight the site is down with "The website server has not been able to respond to your request."

Put it in dev-mode and got a lot of nasty errors telling me that the database had to be repaired.

Guess I would have to run /db/build?flush=1, but how can I do that without beeing able to login??

Need some help!

/PO

Avatar
Nivanka

Community Member, 400 Posts

13 December 2008 at 4:28pm

does it tell you which table is corrupted?

I had the same problem once with an ExpressionEngine website and all I had to do is to repair the table which has got errors.

Try with this reference:

[url]http://dev.mysql.com/doc/refman/5.1/en/repair-table.html[/url]

but f you have a phpmyadmin installed it will be much easier for you to do that.

Avatar
poblom

Community Member, 25 Posts

13 December 2008 at 10:44pm

Thanks Nivanka!

Problem solved!

SiteTree was damaged. Managed to do a "REPAIR TABLE" from phpmyadmin and the site is up and running again. (www.hasselbladfoundation.org)

/PO

Avatar
Nivanka

Community Member, 400 Posts

14 December 2008 at 3:42am

Nice one!