Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

links or images in subpages


Reply


4 Posts   1283 Views

Avatar
janulka

Community Member, 80 Posts

14 December 2008 at 6:28am

Edited: 14/12/2008 6:29am

Hei,
I got problem with my latest site, when i insert image for example in "contact" subpage, SS links it following way:

src="assets/Uploads/IMAGE", thats quite fine i guess?

but then browser is looking for following image including sublink: contact/assets/Uploads/IMAGE

same as links - when i link from contact to f.e. home using href="/home", browser is looking for following: contact/home

weird? help plz? thanks

Avatar
Liam

Community Member, 470 Posts

14 December 2008 at 6:43pm

Do you have $BaseHref in your template?

This really shouldn't be happening if the html is being written with the first slash, regardless of having the base url or not.

Avatar
Sean

Forum Moderator, 922 Posts

14 December 2008 at 11:01pm

<% base_tag %> should be in the <head> of your Page.ss HTML. Alternatively, you can define the <base> tag yourself; <base href="$BaseHref">

Avatar
janulka

Community Member, 80 Posts

14 December 2008 at 11:40pm

yess!

wrote html for Page.ss from scratch and somehow forgot about <% base_tag %> in the <head>, this worked it out, thanks a lot!!