Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Some minor(?) issues - v2.3 rc2


Reply


1585 Views

Avatar
martimiz

Forum Moderator, 1132 Posts

15 December 2008 at 9:14am

Edited: 15/12/2008 9:15am

Encountered the following (minor?) issues in 2.3-rc2:
.
1. A virtual page pointing to a page that has been removed/unpublished will result in an empty menu-item on the website that leads to an empty page - after it has been clicked once. The CMS will let me save new virtual pages that don't refer to any page at all.

2. A redirect page pointing to an invalid page - or no page at all still shows up in the website's menu. When clicked it will display the message 'A redirector page has been set up without anywhere to redirect to'. I would assume it shouldn't be in the menu at all, or at least lead to 'page not found' as visitors have no obvious need for this information.

3. There's no obvious way way to check if virtual pages or redirect pages point to valid pages.

4. The access tab for virtual pages will tell you that none can view the page - which is obviously not true.

5. First level pages seem to have no default settings in the 'access tab'. The option 'Inherit from parent' (default in child-pages) has no meaning in first-level pages, doesn't show in the access tab, but is still set as default (sitetree table).

6. Also in the 'access tab' when 'Only these people (choose from list)' is selected but no viewer group is chosen, the CMS still lets you save the page. (Administrator can still login to the page on the website - is this by design?)

Are there people around who can confirm? I'm not sure if I should make separate tickets for all these kind of things, as they are somewhat minor, or if someone of the dev. team will pick them up from here?