Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

SilverStripe 2.0.2-rc1


Go to End
Reply


38 Posts   75241 Views

Avatar
elijahlofgren

Google Summer of Code Hacker, 222 Posts

14 July 2007 at 4:25pm

> Please let us know of any bugs! :)

Using silverstripe-v2.0.2-rc3, I get this error when I go to /db/build:
Fatal error: Class 'BasiAuth' not found in silverstripe202rc3/sapphire/core/model/DatabaseAdmin.php on line 45

Fix:

--- sapphire/core/model/DatabaseAdmin.php 2007-07-10 23:01:09.000000000 -0500
+++ sapphire/core/model/DatabaseAdmin-fixed.php 2007-07-13 23:20:26.000000000 -0500
@@ -42,7 +42,7 @@

function build() {
if(Director::isLive() && ClassInfo::hasTable('Member') && ClassInfo::hasTable('Group') && ClassInfo::hasTable('Permission')) {
- BasiAuth::requireLogin("SilverStripe developer access. Use your CMS login", "ADMIN");
+ BasicAuth::requireLogin("SilverStripe developer access. Use your CMS login", "ADMIN");
}

$this->doBuild(isset($_REQUEST['quiet']) || isset($_REQUEST['from_installer']));

Hope this helps,

Elijah

Avatar
Sigurd

Forum Moderator, 628 Posts

15 July 2007 at 10:29am

Thanks Elijah. That's a fairly substantial issue to resolve and very minor to fix, so we've released a patch that replaces 2.0.2...

[url]http://www.silverstripe.com/assets/downloads/PHPInstaller/silverstripe-v2.0.2b.tar.gz[/url]

Updating site now...

(I'll make visiting the previous tar gz URL redirect to the new tar gz)

Avatar
Sean

Forum Moderator, 922 Posts

15 July 2007 at 12:16pm

Edited: 15/07/2007 12:16pm

Simple mistake. Looking good now, thanks everyone for the hard work getting this out. :-)

Cheers,
Sean

Avatar
sarahk

Community Member, 46 Posts

20 July 2007 at 4:20pm

Hi

My previous version was silverstripe.2.0.DailyBuild.2007-04-10

And when I try to do anything I get

Fatal error: Interface 'PermissionProvider' not found in /home/mysitenamehere/domains/andrewking.co.nz/public_html/pm/cms/code/CMSMain.php on line 9

I've searched the cms folder and the only file with PermissionProvider in it is CMSMain.php where it implements the class - but the actual class is nowhere to be seen.

I've got to go and do errands and will reinstate the old version after but hopefully there's an easy answer.

thanks

Sarah

Avatar
Sigurd

Forum Moderator, 628 Posts

20 July 2007 at 4:30pm

You've upgraded to 202b then?

... I wonder if there's something in the database as opposed to PHP that's causing this...

Avatar
sarahk

Community Member, 46 Posts

20 July 2007 at 6:01pm

Yes, just downloaded silverstripe-v2.0.2b

Seems I'd missed that Sapphire was still uploading on one of my windows. Worked fine once I'd deleted the old XML file from sapphire/core/XML.php

Sorry about the panic!

Go to Top