Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Installation Finishes but doesn't work


Go to End
Reply


14 Posts   7767 Views

Avatar
Sean

Forum Moderator, 922 Posts

26 July 2007 at 12:28am

Hmm, it seems to be caching the fact it can't find a class, because ?flush=1 fixes it then you take it off and it does it again. Very bizarre... is this the behaviour you're also getting?

Sean

Avatar
Glen

Community Member, 10 Posts

26 July 2007 at 6:58am

Yep - That is the same thing I am getting. It seems to work for a couple of pages and then stops working again. Any suggestions of where to look? log files, etc?

Thanks,
Glen

Avatar
ScottB

3 Posts

13 August 2007 at 1:38pm

I'm also hosting at Webdrive and I get similiar errors. Though adding ?flush=1 to the admin url only fixes it for that pageview the next page view has similiar errors as above.

Avatar
SteveH

1 Post

13 August 2007 at 4:02pm

Web Drive uses Mod Vhost Alias:

http://httpd.apache.org/docs/1.3/mod/mod_alias.html

VirtualDocumentRoot /home/httpd/vhlinks/%0/

I assume the VirtualDocumentRoot is causing the problem for SilverStripe.

Avatar
ScottB

3 Posts

13 August 2007 at 4:35pm

A developer here sorted the issue by changing the core/ManifestBuilder.php line 39

   // Config manifest
//   $baseDir = dirname($_SERVER['SCRIPT_FILENAME']) . "/..";
$baseDir = '/path/to/files';

Now SS is working.. Bout time!

Avatar
mandrew

Core Development Team, 36 Posts

13 August 2007 at 6:52pm

Edited: 13/08/2007 6:56pm

Cheers for that, I have been battling for a little while with webdrive too and only just made a break through today with creating the site on my computer, uploading the whole site via ftp (no ssh... argh!!!), adding ini_set(”memory_limit”,”32M”); in sapphire/main.php (don't quote me on doing this but if it works then cool!!!), removing PHP Safe Mode in the Advanced Settings which achieved a viewable website, then logging into the cms was a problem until adding that fix... awesome!!!!

Go to Top