Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

BlackCandy theme issue when page is greater than 3 levels deep


Reply


8 Posts   2575 Views

Avatar
JoGiles

9 Posts

28 July 2007 at 10:23pm

Hello all,

I am using a blackCandy-based theme on a site I'm involved with, and have come across a need to have a page 'four levels deep'. Therefore, the breadcrumb needs to print three links and then the current page.

My problem is with the sidebar that is printed. Everything is unmodified from the original theme in my version. It all works fine, except for when I go to the four-depth page, which then results in the sidebar being printed incorrectly (fonts get smaller and odd images get in there).

I don't mind the fact that four-depth links won't be printed on the side bar, I just would love to know if there was an easy way to modify the SideBar.ss file such that it did not bother to handle any links deeper than 3 levels deep.

Cheers,
Jonathan Giles.

Avatar
Willr

Forum Moderator, 5513 Posts

29 July 2007 at 11:49am

Hey Jonathan, Thanks for the feedback. I have had a quick play around with it and I hope this will fix it for you!. The sidebar menu is quite complex due do that nested menu inside a nested menu and things can get pretty crazy!

I have attached the new layout.css and I had to tidy up IE7 so you will need to replace ie7.css as well.

Let me know if anything comes up!

Avatar
JoGiles

9 Posts

29 July 2007 at 12:10pm

Edited: 29/07/2007 12:19pm

Hey, Thanks for this. I am giving it a go now (got to manually find the changes between your files and my ones)

Avatar
Willr

Forum Moderator, 5513 Posts

29 July 2007 at 12:19pm

Its just all the #Sidebar stuff if that helps

Avatar
JoGiles

9 Posts

29 July 2007 at 12:21pm

Hey, cheers, I gave it a go but there are still some font-size issues. I will just double check everything now and get back to you. If you run MSN messenger, my email is Jo@JoGiles.co.nz.

Avatar
Willr

Forum Moderator, 5513 Posts

29 July 2007 at 12:30pm

Sorry about that, I'll give you a buzz on msn and see whats up!

Avatar
JoGiles

9 Posts

29 July 2007 at 12:31pm

I just fixed the issue - it seems your updated layout.css was missing a line I had in mine, so I commented it out. I would think that it should still be in your css file however. It is in:

#Sidebar li a.current:hover

You should include

font-size: 1.2em;

That fixes the problem for me, and now the theme once again seems to work as expected.

Avatar
Willr

Forum Moderator, 5513 Posts

29 July 2007 at 12:42pm

Nice work! I will make sure the template has these changes