Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

v2.0 stable Install problem


Reply

6 Posts   1733 Views

Avatar
kenlomax

5 February 2007 at 11:41pm (Last edited: 5 February 2007 11:42pm), Community Member, 33 Posts

When trying to install v2.0 stable the installaton gets to

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)
# Creating 'assets' folder...
# Creating 'mysite/_config.php'...
# Creating '.htaccess' file...
# Building database schema...
# Waiting until the the database is created before compiling the manifest

Fatal error: Cannot redeclare class db in /var/www/html/silverstripe20/sapphire/core/model/DB.php on line 7

THe installation then stops and nothing seems to get it to go any further.

Ken

Avatar
Sam

7 February 2007 at 9:08am Administrator, 685 Posts

What version of PHP are you using?
Have you defined a class called "db" yourself?

Avatar
kenlomax

7 February 2007 at 10:05am Community Member, 33 Posts

I am using php version 5.1.6 and I have not created a db class

Ken

Avatar
Andy

7 February 2007 at 10:50am 230 Posts

Perhaps you have the PEAR db package installed?

Avatar
kenlomax

7 February 2007 at 1:25pm Community Member, 33 Posts

Thanks to sterling work done by Sam, this problem has been solved.

What happened is that I created a new folder in my web document tree (/var/www/html/silverstripe20) and copied the php installer tarball into it.

I then unpacked the tarball and it created a folder at the same level called silverstripe-v2.0. As I did not want to use a long hierarchy of directories to call SilverStripe I copied all the files out of the new folder to the parent folder and then tried to install there.

The message shown in the previous post was caused because the installer did not ignore the silverstripe-v2.0 folder but went down into it. By the sound of the error message, it tried to use sapphire etc files in that subfolder also.

The fix was to delete the subfolder. I also deleted the tarball there as well (I have a separate copy saved on my machine should I need it later)

All fixed :)

(Is this something that should be incorporated in the next installer-a check for a silverstripe subfolder? Would there be a valid reason for having a folder with such a name in the lifecycle of the CMS? )

Once again, thanks to Sam for his assistance

Regards
Ken

Avatar
Sam

7 February 2007 at 3:34pm Administrator, 685 Posts

Happy to help, Ken :-)

You're right, we should add a check for this. I've put it on the to-do list for v2.1.