Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Tutorial:2 error RSS


Reply


2 Posts   2431 Views

Avatar
Fuchur

4 Posts

12 August 2007 at 9:45pm

Working my way through the great tutorials.

Main issue I have issues with at the moment is getting the RSS to work.
Did everything according to the tutorial and checked it with the files you can download in tutorial 3 and should all be in place.

I installed SS on a local wamp server.
Using Firefox I get this error:

FATAL ERROR: Cannot modify header information - headers already sent by (output started at D:\Sites\CmsSilverstripe\tutorial\code\ArticlePage.php:34)
At line 43 in D:\Sites\CmsSilverstripe\sapphire\api\RSSFeed.php

header(Content-type: text/xml)
line 43 of RSSFeed.php

RSSFeed->outputToBrowser()
line 24 of ArticleHolder.php

ArticleHolder_Controller->rss(Array)
line 130 of Controller.php

Controller->run(Array)
line 12 of ModelAsController.php

ModelAsController->run(Array)
line 48 of Director.php

Director::direct(/news/rss)
line 101 of main.php
Context
Debug (Debug::showError() in line 133 of Debug.php)

Second thing is that all the online tutorials refer to "mysite" while you should change the "tutorial" just a small thing but sometimes you forget and cut and paste code and it doesnt work you start getting %$^%$^ ... now I know :P

As said working my way through and so far looks great! Very anxious to see what the GSoC brings us!

Thanx 4d Reply!
Fuchur

Avatar
elijahlofgren

Google Summer of Code Hacker, 222 Posts

14 August 2007 at 3:19pm

> FATAL ERROR: Cannot modify header information - headers already sent by
(output
started at D:\Sites\CmsSilverstripe\tutorial\code\ArticlePage.php:34)

Check that D:\Sites\CmsSilverstripe\tutorial\code\ArticlePage.php does not have any spaces at the end after the ?>

> Second thing is that all the online tutorials refer to "mysite" while you should change the "tutorial"

It wold be great if you would register ([url]http://doc.silverstripe.com/doku.php?id=start&do=register[/url]) and then login ([url]http://doc.silverstripe.com/doku.php?do=login&id=start[/url]) and fix anything you see needs fixing. ;)

I hope you continue to enjoy SilverStripe. :)

Hope this helps,

Elijah Lofgren