Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

.htaccess REQUEST_URI


Reply


5 Posts   2444 Views

Avatar
vevmesteren

7 Posts

16 August 2007 at 5:47am

I think I have tracked this problem that I am having.
I am currently with 1and1.com where I have a hosting package that permitted me to install silverstripe. But, now I keep on getting 404s when trying to access the silverstripe dir. The database was created, and the filestructure seems to be inplace. But it seems that the URL that silverstripe thinks it is one is not the correct. Is there a way for me to globally modify my base URL like one can in a Wordpress blog administration?

Thank you

V

Avatar
vevmesteren

7 Posts

16 August 2007 at 6:15am

Maybe it is not the REQUEST_URI, but it something like it. I found that the silverstripe thinks that the files are stored under /kunden/homepages/25/d210714655/htdocs/silverstripe/, which I guess probably is right when wanting to access the files on the server, but not via the URL as the virtual directory points directly to the htdocs. So I just need it to be set to silverstripe, short and sweet. How would I be able to do that?

thanks

Avatar
vevmesteren

7 Posts

19 August 2007 at 11:18am

anyone? Please? I really want to start exploring silverstripe, but cannot for the moment...

V

Avatar
Andy

230 Posts

20 August 2007 at 9:28am

Try changing the $baseDir on line 39 of Manifest builder, as in this thread: [url]http://www.silverstripe.com/bugs/flat/2837?start=8[/url].

Avatar
Tim

Core Development Team, 201 Posts

20 August 2007 at 10:10am

Should we set this variable in a more global configuration file for future releases?