Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

I cant get Mashups to work


Reply

3 Posts   1711 Views

Avatar
BeefStake

17 August 2007 at 5:03pm 23 Posts

Ive reinstalled twice and still no luck
Currently just testing on my box at home...
received this error on both installs.

Fatal error: Call to undefined function curl_init() in G:\WAMP\www\test\mashups\code\RestfulService.php on line 37

Any ideas....

Thanks in advance

Avatar
Matt

18 August 2007 at 12:23am Core Development Team, 84 Posts

Looks like curl isn't installed, or isn't loaded.

If you're using WAMP, left-click on the icon in your system tray, select 'PHP Settings', then 'PHP extensions' and then look for php_curl. Click it, wait for your server to restart and try again.

If that doesn't solve it, you'll need to check if WAMP has edited the right PHP file. When I last installed WAMP, it made two copies of the file, the one it was editing was not the one that PHP was loading. (There was one in Apache's bin directory and one in PHP's root directory).

Hope that helps you out.

@lakshan: Might be a good idea to wrap the curl_init() call around a function_exists() call, like so:

<?php
if(function_exists('curl_init')) {
// Call curl_init(), setup object etc
} else {
return null;
}
?>

Avatar
BeefStake

18 August 2007 at 8:05am (Last edited: 18 August 2007 8:10am), 23 Posts

Cheers Matt
::worships apt-get install curl::

//Edit: That fixed it, I'm using a customized build of Debian thats workstation orientated than server based, i didn't actually include apache in my list of required stuffs.... Thank you for your help