Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Parse error when install.php is opened...


Reply

8 Posts   2661 Views

Avatar
TweeQer

9 February 2007 at 8:04am Community Member, 1 Post

When I try to run install.php I get this error:

Parse error: parse error, unexpected T_OBJECT_OPERATOR in /home/www/public_html/web/install.php on line 536

What should I do? Any help would be great!

Thank you!

Avatar
Sigurd

9 February 2007 at 12:31pm Forum Moderator, 628 Posts

I wonder if you are using PHP4? What version are you using? Looking at install.php, you can probably take out the if { } and get passed that particular parse error, but I think there may be something wrong with your server config that will mean you won't get much further;

535: // Populate initial content
536: if(!DB::query("SELECT ID FROM SiteTree WHERE URLSegment = 'about-us'")->value()) {
537: echo "<li>Populating initial content and administrative account</li>";
538:    flush();
539:
540: $dbAdmin->populate();
541: }

Keep line 540 to populate the content but lose everything else.

Avatar
Sean

12 February 2007 at 11:20am Forum Moderator, 921 Posts

Chances are you're using PHP4, if you can, modify the .htaccess file on your host and add this line - provided that your host also has PHP5 alongside 4. I had the same problem.

AddType application/x-httpd-php5 .php

Avatar
pabben

21 February 2007 at 5:12am Community Member, 1 Post

Hi, i have the same problem, but.....i have a Joomla installation runing in the same host, i can modify the .httpaccess file, but how can i make the change only for the directory where i'am triying to install silverStripe?
Thanks

Avatar
browserweb

6 April 2007 at 2:29pm (Last edited: 6 April 2007 2:30pm), Community Member, 2 Posts

I have the same issue and so I did upgrade to PHP5 - that didnt work. I followed the instructions and also took out the code suggested by Sigurd and entered the new db info I created as that was the next error... that didnt work...any suggestions?
Cheers

Avatar
Sean

6 April 2007 at 4:02pm Forum Moderator, 921 Posts

Have you tried using the latest release candidate (rc5) as of this time?

http://www.silverstripe.com/assets/rc/silverstripe-v2.0.1-rc5.tar.gz

Please let us know if you're still getting the same problem with this version.

Avatar
Sean

6 April 2007 at 4:03pm Forum Moderator, 921 Posts

pabben: can you not put a seperate .htaccess file in the directory where you have SilverStripe installed?

Avatar
browserweb

7 April 2007 at 3:53am Community Member, 2 Posts

New version worked sweet, thanks.