Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

mod_rewrite doesn't appear to be working ... and again


Reply


2 Posts   2248 Views

Avatar
smordi

9 Posts

26 August 2007 at 7:13am

Hi!
Thanks a lot for such a wonderful CMS!
At home on my local apache everything works fine.
But when I try to install the CMS on the provider's system, then I get even after trying lots of time the message:

mod_rewrite doesn't appear to be working. Make sure:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway.

I tried to change the .htaccess: nothing happened. Mod_rewrite is enabled, I already had a call to my provider (all-inkl.com) and they confirmed it.

And if I am going on to proceed anyway, the "Install was successful", but there are some php-warnings at the top of the page:

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../_ss_environment.php) is not within the allowed path(s): (/www/htdocs/v155019/:/tmp:/usr/bin:/www/htdocs/v155019:/bin:/usr/local/bin:/usr/share/php) in /www/htdocs/v155019/sapphire/main.php on line 40

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../../_ss_environment.php) is not within the allowed path(s):

Any ideas?
Maybe one solution could be a change in the php.ini, but I do not have access to it.

Best

smordi

Avatar
smordi

9 Posts

26 August 2007 at 7:33am

ok, i fixed the problem by going on searching in the forums...

First changing the .htaccess to:

RewriteEngine On

RewriteRule \.js$ - [L]
RewriteRule \.css$ - [L]
RewriteRule \.png$ - [L]
RewriteRule \.jpg$ - [L]
RewriteRule \.gif$ - [L]
RewriteRule \.php$ - [L]

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

and afterwards remobing the lines 38-44 of main.php - the stuff about envFiles... fixed the problem, see topic:
http://www.silverstripe.com/general-discussion/flat/3009

ok, cheers!