Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

User Form editor & screen size


Reply


3 Posts   2067 Views

Avatar
Fuzz10

Community Member, 787 Posts

3 September 2007 at 8:44pm

Edited: 03/09/2007 8:47pm

When creating a long form the grey bar ("email submission to : etc. etc.") obstructs the lower form elements. See screenshot.

Avatar
Iain_vdw

Community Member, 22 Posts

4 November 2008 at 9:20pm

Edited: 04/11/2008 10:25pm

I'm giving this thread a shameless bump, because i'm having the same issue with my long forms. It's a bit surprising that this isn't fixed after more than a year.

I've tried digging into the CSS files of the editor (because i think it's CSS related). Firefox displays the form editor correctly actually, but IE7 (and possible earlier versions) are giving trouble with long forms in the backend editor.

Has anyone tried to solve this or actually found the culprit that's causing this...?

Edit:
I've found a temporary solution:
In sapphire\css\FieldEditor.css, uncomment overflow-y:scroll at:

   div.FieldEditor div.FieldList {
      background-color: white;
      border-bottom: 1px solid #CCCCCC;
      border-top: 1px solid #CCCCCC;
      height: 75%;
      overflow-y: scroll;
   }

And in the same file, comment out position:relative at:

#right #Form_EditForm div.EditableMultiOptionFormField div.FieldDefault ul.EditableDropdownOptions {
   border: solid 1px #7F9DB9;
   /* IE */
   margin: 0px;
   /* display: none; */
   display: block;
   /* position: relative; */
}

Not the best solution there is, it adds a scroll bar to the editable fieldlist which expands and contracts correctly in IE7. Firefox works like it's supposed to, no changes there i've seen this far with this solution.

I hope this helps some people. If anyone finds a better solution, don't hesitate and post it here please!

Avatar
OnebyOne

Community Member, 54 Posts

5 November 2008 at 6:29am

i have the same problem in IE

The problem doesn't appear in FF 3.0