Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Cannot access Admin Section


Reply


4 Posts   1958 Views

Avatar
Pete

4 Posts

7 September 2007 at 7:59am

Hi,

First of all what a great product. I have installed, with no issues, SilverStripe on a hosted server. the problem i have is that i cannot access the admin section of the web site. When i enter the http://hostname/admin URL i receive a page cannot be found error. See Below

Page not Found

Sorry, it seems you were trying to access a page that doesn't exist.

Please check the spelling of the URL you were trying to access and try again.

I am sure this is an htaccess issue below is what i am using:

### SILVERSTRIPE START ###
RewriteEngine On

RewriteRule ^online$ - [L]
RewriteRule ^online/.* - [L]

RewriteRule \.js$ - [L]

RewriteRule \.css$ - [L]

RewriteRule \.png$ - [L]

RewriteRule \.jpg$ - [L]

RewriteRule \.gif$ - [L]

RewriteRule \.php$ - [L]

RewriteCond %{REQUEST_URI} ^(.*)$

RewriteCond %{REQUEST_FILENAME} !-f

RewriteRule .* /sapphire/main.php?url=%1&%{QUERY_STRING} [L]

### SILVERSTRIPE END ###

Kind regards,

Peter

Avatar
Bladeex1

3 Posts

8 September 2007 at 4:43am

Edited: 08/09/2007 4:51am

I got the same error but just added another rewrite rule and everything worked out as far as accessing the page and getting the install to complete.
RewriteEngine on
RewriteBase/
RewriteRule ^9([a-z]+)\.html$/index.php?$1
[R,L]6:26

That seemed to work as far as getting the install to complete. I'm having other issues that seem to be related. I have a screen shot uploaded of what I am seeying.

Also I was just looking at the code on the admin page and if I go directly to the link:
http://agzonline.agzmarketing.com/admin/newsletter/ Then I get a page so there has to be some problem with the splash page or the cpanel for the cms. Have you guys ever seen this or any of the issues above?

Avatar
Bladeex1

3 Posts

11 September 2007 at 6:14am

Wow where is that support I heard about. This seems like a simple issue and I'm sure that someone can answer it.

Avatar
Andy

230 Posts

11 September 2007 at 1:09pm

Most likely this is a javascript error - try getting [url=http://www.getfirebug.com]firebug[/url] and checking the debug console for errors - then we might be able to figure out what's going on. Also, try the latest [url=http://dailybuilds.silverstripe.com]daily build[/url] and see if that works for you.