Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

security system, no users shown....


Reply

18 Posts   12393 Views

Avatar
Decisive Flow

22 April 2008 at 8:07am Community Member, 73 Posts

Doesn't work for 2.2

It seems crazy in a basic silverstripe installation, I can't add, view or edit users.

The one I added through the database to a user group with no permissions (as told to in order to see restricted front end pages) just keeps redirecting back to the login page.

Help!!!!

Avatar
rino

14 May 2008 at 10:33pm Community Member, 12 Posts

some other problem i noticed: i think the whole ajax system (showing list of possible accounts while typing etc.) has a problem if you have your PHP configuration (php.ini) on
error_reporting = E_ALL (shows all PHP errors and notices). the ajax response will then contains notices about undefined variables at the beginning, for example:

<code>
<b>Notice</b>: Undefined variable: result in <b>C:\DATA\PHP_Eclipse_Workspace\P503_ZOFINGIA_WEBSITE

\htdocs\cms\code\SecurityAdmin.php</b> on line <b>99</b><br />

on my system this prevented the popup list with the possible accounts from showing...

as soon as i change the php.ini file to "error_reporting = E_ALL & ~E_NOTICE" and restart apache it starts to work again.