Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Error saving content


Go to End
Reply


14 Posts   9338 Views

Avatar
dio5

Community Member, 501 Posts

12 September 2007 at 6:18am

And another thing: wouldn't it be better to say: "RightContent" => "HTMLText" when using a new HtmlEditorField?

Sorry for all the questions.. I'm only beginning here :-)

Avatar
Tatey

Community Member, 18 Posts

27 November 2007 at 6:14pm

Are you aware if mod_security is enabled on your HTTP server? It has rather conservative settings. It's not uncommon for mod_security to identify a "Page Save" as an SQL injection attack and deny the query.

You could attempt to disable mod_security by appending the following lines in your .htaccess. This file resides in your SilverStripe root directory.

<IfModule mod_security.c>
SecFilterEngine off
</IfModule>

Avatar
redking

43 Posts

25 January 2008 at 11:52am

Edited: 25/01/2008 6:03pm

I'm experiencing the same "Error saving content" with the ArticlePage. Oddly enough, it saves and publishes the content until the browser cache is cleared, then it's gone. Weird. Any fixes for this?

Avatar
dospuntocero

Community Member, 54 Posts

29 June 2008 at 10:46pm

same error here... the content is saved, but it keeps me saying "error saving content" my field is created as follows:

static $db = array(
   'CostIncludes' => 'Text'
)
function getCMSFields() {
   $fields->addFieldToTab('Root.Content.Main', new HtmlEditorField('CostIncludes','Cost includes'));
   return $fields;
}

Avatar
Willr

Forum Moderator, 5513 Posts

30 June 2008 at 2:26pm

You are using a HtmlEditorField. Note that you have to use the FieldType of "HTMLText" instead of "Text" if you want to use a HTMLEditorField to edit it

Avatar
dospuntocero

Community Member, 54 Posts

1 July 2008 at 3:52am

dumb me... thanks for noticing the problem :)
now all is working perfect!

Go to Top