Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

The new version of the gallery module has been released


Go to End
Reply


12 Posts   4468 Views

Avatar
The Frenchy

Core Development Team, 40 Posts

21 September 2007 at 6:38pm

Edited: 26/09/2007 1:25pm

The [url=http://www.silverstripe.com/assets/downloads/modules/gallery-0.2.1.tar.gz]gallery module version 0.2.1[/url] is now available.

In the new features, there are :
- More media files usable in the gallery
- Easy way to manage the file extensions
- The last version of the lightwindow has been added
...

Requirements : The version 2.1.0 of Silverstripe

More details and the documentation will be available soon.

Avatar
Willr

Forum Moderator, 5513 Posts

24 September 2007 at 5:56pm

wicked! nice work Romain!

Avatar
The Frenchy

Core Development Team, 40 Posts

26 September 2007 at 1:23pm

If you want to know all the improvements which have been done on the gallery module and how to use the new functionalities, check the [url=http://doc.silverstripe.com/doku.php?id=gallery]documentation[/url].

Avatar
lancer

57 Posts

30 September 2007 at 12:27am

Great work. Especially the prev/next was missed in the previous versions. It might be worthile noting that upgrading has issues, because of the added functionality. You'll have to go into the properties of each gallery to correct it. The pages are still there, but I lost the association with the gallery directory (and so no pics after upgrading).

There is one piece of functionality I'm missing though. The previous popup window had a link to the original image. Is there a way to bring that one back?

Avatar
Reflektera

49 Posts

30 September 2007 at 1:02am

I have trouble saving a page as gallerypage. I just get a error saving. Anyone else having trouble with this?

Avatar
lancer

57 Posts

30 September 2007 at 1:24am

Edited: 30/09/2007 1:28am

Upgrade or Fresh install?

In the first case; /db/build?flush=1 ? I upgraded and I can create new gallery pages.

Also; permissions in the assets/gallery folder ?

Avatar
Reflektera

49 Posts

30 September 2007 at 1:46am

Fresh install, I've tried to flush and still I get the error. Should the gallery create the gallery-folder by itself? Here, it don't do that. Permissions on the assets folder is 777.

Avatar
lancer

57 Posts

30 September 2007 at 4:38am

I have some problems with associating a default image with the gallery. If I insert one from the file store, it works well. If I want to replace it with something from the filestore, I get no listing in the drop down list. If I remove it, it is also removed from the filestore and thus the photo gallery. For me, this was unexpected behavior.

Go to Top