Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Errors Installing with Xamp


Go to End
Reply


10 Posts   5558 Views

Avatar
Marcus

Administrator, 87 Posts

4 March 2007 at 1:30am

In php.ini there'll be a property called "memory_limit = 8M" or similar. Or, try "ini_set('memory_limit', '8M')" at the top of sapphire/main.php.

Avatar
jansie

Community Member, 1 Post

30 August 2008 at 7:53am

hi,

i tried installing SS, and came across an error right at the start. i found this thread, and followed all the instructions.

mod_rewrite is enabled. here's the line:
LoadModule rewrite_module modules/mod_rewrite.so [i activated this]

in php.ini, the memory limit line reads as follows:
memory_limit = 32M ; Maximum amount of memory a script may consume (16MB) [this is standard]

in sapphire/main.php, the memory line reads as follows:
ini_set('memory_limit', '32M'); [this is standard]

i added a password to the user. user is root, and password is something i'm not comfortable sharing here ;-)

this is the first message i receive, after trying to install:

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating C:\xampp\htdocs\nmcbusiness/mysite/_config.php
# Creating '.htaccess' file...
# Creating C:\xampp\htdocs\nmcbusiness/.htaccess
# Building database schema...
# Checking mod_rewrite works
# http://localhost/nmcbusiness/InstallerTest/testrewrite Rewrite is DirectorySlash Off RewriteEngine On RewriteBase /nmcbusiness RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$ RewriteCond %{REQUEST_URI} ^(.*)$ RewriteCond %{REQUEST_FILENAME} !-f RewriteRule .* C:/xampp/htdocs/sapphire/main.php?url=%1&%{QUERY_STRING} [L] Creating C:\xampp\htdocs\nmcbusiness/.htaccess http://localhost/nmcbusiness/InstallerTest/testrewrite
# ERROR: mod_rewrite not working, redirecting to mod_rewrite test page
# Creating C:\xampp\htdocs\nmcbusiness/.htaccess I will now try and direct you to rewritetest to troubleshoot mod_rewrite

this is the final message:

Warning: file_get_contents(http://localhost/nmcbusiness/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. in C:\xampp\htdocs\nmcbusiness\rewritetest.php on line 47

Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\nmcbusiness\rewritetest.php on line 47

it creates 54 tables in the database (if this info is important)

i run xampp 1.6.7 on vista home premium. machine is toshiba. 3Gb ram. 1.83 Ghz intel core 2 duo.

any ideas? i'm really amped to use this CMS. seems wonderful.

Go to Top