Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Installing 2.0


Go to End
Reply


10 Posts   4803 Views

Avatar
senojeel

Community Member, 3 Posts

16 February 2007 at 11:06am

I am trying to test out version 2.0. After the installation it takes me to a page that says "The requested URL /silverstripe/home/successfullyinstalled was not found on this server." I checked my .htaccess and it put in these conditions:

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* /silverstripe/sapphire/main.php?url=%1&%{QUERY_STRING} [L]

Any ideas how I can get this install to finish?

Thanks!
Shawn

Avatar
Andy

230 Posts

16 February 2007 at 11:26am

Try changing the rewrite rule to

RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

Avatar
Aaron

Community Member, 63 Posts

16 February 2007 at 11:48am

I get exactly the same. I tried that Rule change but it has no affect.

Avatar
Andy

230 Posts

16 February 2007 at 3:33pm

The only thing I can think of right now is that mod_rewrite isn't enabled, although the installer should've picked that up..

Avatar
Sigurd

Forum Moderator, 628 Posts

16 February 2007 at 4:02pm

Are you certain the .htaccess file is being read? There is a setting that you need to turn on in Apache for it to process .htaccess files...

You could try to put in something non sensible in the .htaccess file (e.g. make thoe whole file just say "abc123", to provoke a "HTTP 500 Internal Server Error", which is a good test that the .htaccess file is being parsed.

Avatar
kenlomax

Community Member, 33 Posts

16 February 2007 at 6:59pm

I had the same problem with earlier installs. The solution was to add the following to the httpd.conf file

<Directory /var/www/html/silverstripe> //or whatever your install directory is
AllowOverride All
</Directory>

Hope this helps

Ken

Avatar
senojeel

Community Member, 3 Posts

17 February 2007 at 2:32am

Thanks Ken.

That worked great for me!

Shawn

Avatar
senojeel

Community Member, 3 Posts

17 February 2007 at 4:35am

I thought it worked...

I restarted my machine and now it doesn't work. I get the same thing I did originally. I went back to my httpd.conf and made sure the adde lines were there and they were. I checked my .htaccess to make sure it was still there and it looked fine. Any idea why this would happen?

Shawn

Go to Top