Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

/home = Bad SEO


Go to End
Reply


12 Posts   6423 Views

Avatar
Tatey

Community Member, 18 Posts

6 March 2008 at 7:29pm

Edited: 06/03/2008 7:33pm

You're full of solutions, aren't you dio5? Thanks *very* much for this. Perhaps it's worth adding to the ticket?

Avatar
Fabie

Community Member, 28 Posts

13 March 2008 at 10:53pm

Thanks again dio5,

This was an excellent fix and it now seems that the homepage is indexed with Google.

Now we only need a fix from the SilverStripe dev team to change that 302 into a 301 and my sites search engines rankings will be extremely happy!

Thank you again so much, you provided extremely valuable help.

fabie

Avatar
Sigurd

Forum Moderator, 628 Posts

14 March 2008 at 9:34am

Dios, can you provide your /home/ fix as a patch at open.silverstripe.com (and your 301 header too). It's hard for us to manage patch submissions in the forum, and then you'll be given the credit for the work. Thanks very much!! :)

Avatar
mundgold

Community Member, 19 Posts

15 March 2008 at 12:19am

Edited: 15/03/2008 12:21am

Hi, I have a problem with the GoogleSitemap.php
Alle Pages will displayed in sitemap.xml even if I set the Pageproperty in the Backend to "not index".
The entry in the database will be "null" - but the output in the sitemap.xml will be 0.7

I tested this in sapphire/misc/GoogleSitemap.php and checked the output from "$page->Priority" and that will be a string from 0.1 to 1 (in accordance with my settings in the backend for the page) - but if I set it to "not index" i get a float 0.7

Could anybody help?

Thanks a lot Roland

Go to Top