Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Gallery 0.2.1


Reply

6 Posts   1835 Views

Avatar
thbeh

3 October 2007 at 1:30pm Community Member, 6 Posts

Could not get the gallery module to work. Any pointers?
I also read through the tutorial and wondering where should I put <% include GalleryPageContent %> because i can't find the GalleryPage.ss

Thanks

Avatar
Willr

3 October 2007 at 5:13pm Forum Moderator, 5511 Posts

GalleryPage.ss should be in the gallery/templates/layout/GalleryPage.ss or you can override this is your theme folder.

Could not get the gallery module to work?

First off have you rebuilt the database which should add a couple of things like GalleryPage to the database

Avatar
thbeh

3 October 2007 at 5:28pm Community Member, 6 Posts

Yes, the db have been rebuild and did not notice any errors. I could not find the path to the GalleryPage.ss file. I have checked the tar file and it is also not in there.
Thanks

Avatar
Willr

3 October 2007 at 5:36pm (Last edited: 5 October 2007 9:27am), Forum Moderator, 5511 Posts

ah it looks like there is no GalleryPage.ss anymore included within the module. So what you must do is make a GalleryPage.ss inside themes/your_themes/templates/Layout/ and add the <% include GalleryPageContent %> or you can add that to the themes/your_themes/templates/Layout/Page.ss file somewhere in with $Content, $Form etc.

Avatar
thbeh

3 October 2007 at 9:34pm Community Member, 6 Posts

Ok. That seems to work. Thanks a lot.

Avatar
Balajee

12 October 2007 at 8:57am 2 Posts

Hi , I am trying to get the gallery module intergrated to the silverstripe.

I downloaded the gallery module onto the root, ran /db/build from the silverstripe url,

I added the <% include GalleryPageContent %> themes/blackcandy/templates/Layout/Page.ss

After refreshing the page with flush
i dont see the galley tab , nor the cms displays and gallery page.

What am i missing out here, any help would be greatly appreciated.

Thanks,Balajee