Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Strange behaviour can't access admin or site


Reply


6 Posts   1642 Views

Avatar
trevor

53 Posts

9 October 2007 at 11:08am

Hi,

I've been working away most of the day on a new site and then hit a problem. First pages stopped displaying and then I couldn't access the database. I've checked my code and even undone some of the later changes which have only been to templates and filter on some getData queries.

Now the site doesn't display and I can't access the cms via admin (Security/login).

The only other thing I was doing before this was duplicating some pages and moving them into new sections.

It seems that something has happened with the database but I don't no what can anyone give me any ideas of things to check or any debug url parameters ?debug=1 return nothing either.

TIA

Trevor

Avatar
Willr

Forum Moderator, 5513 Posts

9 October 2007 at 5:54pm

Do you receive any errors or just a blank page when visiting the admin section?? I assume you have rebbuilt the database and tried all the normal ?flush=1 refreshing methods

Avatar
trevor

53 Posts

9 October 2007 at 7:46pm

solved but thanks for your response.

I chatted on IRC and through this found the problem which was a typo mistake by me. :)

I had left the comma on a getData filter by mistake and you know how it is it doesn't matter how hard you look you just don't see it sometimes. Anyway the php.log revealed a parse error although I'm not sure why nothing was shown in the browser or why this affected the cms too.

I had tried the db/build and flush but these wheren't showing and results either.

Thanks again.

Trevor

Avatar
Dave_

4 Posts

9 October 2007 at 10:32pm

I'm experiencing the same problem. My admin login panel is displaying correctly but I can't access (login) the cms. No errors apears. I'm doing only small changes for translation in silverstripe-v2.0.2b\sapphire\core\model\GhostPage.php file. I'm asking for a solution or tip.

Avatar
trevor

53 Posts

10 October 2007 at 5:24am

I've never changed the GhostPage before but I normally extend the existing class rather change the current.

I did once by mistake change Page.php and this seemed to mess everything up so I don't know if this is something for you to look at. all i can suggest is check your code again as already said I had left a comma in by mistake so the php parser was erroring the code and check your log files.

HTH

Trevor

Avatar
Dave_

4 Posts

12 October 2007 at 2:03am

Thanks Trevor. It seems to be a good advice. Now i have almost 50% of silverstripe translation to polish language.

Good luck.