Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

ImageField form 'page not found'. Possible mod_rewrite issue?


Reply

4 Posts   1817 Views

Avatar
streetdaddy

16 October 2007 at 12:01pm 32 Posts

I have developed a site using Silverstripe 2.1.0 on a Windows PC using XAMPP. This has worked perfectly on my local machine and I've been able to create a great site. However I've struck some problems when I've moved the site to the live hosting (unix).

I think I have narrowed it down to a mod_rewrite problem. I can navigate the public site ok, but its the CMS where I think this problem manifests itself in a number of ways:

1. When editing a template that has an ImageField, there is a problem with the URL used for the iframe (see Screenshot 1 attached). However, the URL works ok if I pass the URI in the query string (see Screenshot 2 attached).

2. The File and Images section displays a similar behaviour (see Screenshot 3 attached). Once again, a query string method can be used to get to some of the pages that won't load in an iframe (eg. ?url=/admin/assets/uploadiframe/roo)

3. As does the the Security section (see Screenshot 4 attached) for both listing current users, or trying to add a new one.

Unfortunately I have no access to the apache config for the live host, but I am going to contact them asap to find out about some of the directory permissions that are currently setup, such as AllowOverride.

Has anyone seen a problem similar to this before?

A few things to note:

* I have confirmed that all the server requirements are met on the live host (unix)
* I have tried using the database and source from my local development site
* I have also tried using a fresh install of 2.1.0

Avatar
streetdaddy

16 October 2007 at 12:02pm 32 Posts

and the screenshots...

Avatar
streetdaddy

16 October 2007 at 12:03pm 32 Posts

lets try that again...

Avatar
streetdaddy

16 October 2007 at 10:19pm 32 Posts

I never did find a solution to this problem, but I think it was a host configuration problem. I tried a few different hosts and managed to get it working on both Dreamhost and Quadra Hosting.