Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

building database error


Reply


3 Posts   1755 Views

Avatar
nicb07

4 Posts

17 October 2007 at 3:54am

Hi,

I'm trying to follow the first tutorial and have got to the 'Using a different template for the home page' section and am trying to rebuild the database using http://localhost:3000/db/build?flush=1. It creates some table then I get an error:

FATAL ERROR: DATABASE ERROR: Couldn't run query: SHOW FULL FIELDS IN `VirtualPage` | Can't create/write to file 'C:\WINDOWS\TEMP\#sql_158_0.MYI' (Errcode: 17)
At line 386 in C:\lighttpd\htdocs\sapphire\core\model\Database.php

Debug (Debug::showError() in line 147 of Debug.php)
msg =
Couldn't run query: SHOW FULL FIELDS IN `VirtualPage` | Can't create/write to file 'C:\WINDOWS\TEMP\#sql_158_0.MYI' (Errcode: 17)
errorLevel =
256

Anyone experienced this error before?

Thanks

Nicki

Avatar
xeraa

Google Summer of Code Hacker, 58 Posts

17 October 2007 at 6:13am

it could be related to missing right (does your current user have full rights in the temp folder?) or to the virus scanner (somehow locking files while scanning them and causing this problem).

i would check permissions first and then try to disable the virus scanner while installing.

Avatar
nicb07

4 Posts

18 October 2007 at 2:08am

Cheers! got it working now :-)