Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

setting 'allow_wysiwyg_editing' crashes site (using blog-v0.3.0)


Reply

3 Posts   1252 Views

Avatar
weareorganism

30 March 2010 at 3:38pm (Last edited: 30 March 2010 3:39pm), Community Member, 14 Posts

Hi there,

When I enable TinyMCE editing by adding the line "BlogEntry::allow_wysiwyg_editing();" to the _config.php file associated with the blog module I can no longer access my site.

Firefox 3.6.2 reports that there is a Content Encoding Error: The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

IE 8 just fails

Safari 4.04 reports that Safari can’t open the page “[url removed by author]”. The error is: “cannot decode raw data” (CFURLErrorDomain:-1015) Please choose Help > Report Bugs to Apple, note the error number, and describe what you did before you saw this message.

If I modify the BlogEntry.php file directly and hardcode the setting to true everything works as expected.

Has anyone else had this issue? Am I doing anything wrong?

Thanks,
Peter

Avatar
ganassa

9 April 2010 at 2:27am Community Member, 1 Post

Hi
I've just set up _config.php with the "BlogEntry::allow_wysiwyg_editing();" entry, and it works for me (SS 2.3.7 + blog 0.3.0)

Avatar
weareorganism

15 April 2010 at 1:09pm Community Member, 14 Posts

UPDATE:

Seems my issue is caused by having this added to my config file as per another user's suggestion elsewhere in the forum:

ob_start("ob_gzhandler");

I have since removed the line and everything is working fine. Makes sense that a compression error is stemming from a compression handler.

Incidentally I'm running the site on a shared hosting package on Dreamhost.

Thanks,
Peter