Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

No Blog Entries in Blog Holder


Reply


3 Posts   1120 Views

Avatar
cdeangelus

Community Member, 2 Posts

23 July 2010 at 3:12am

Hi there. I just installed the blog module. I haven't changed a thing. My SS installation has a BlogHolder page, and a single post under it. When I go to the BlogHolder page in my browser to look at it, there are no blog post listings. The page exists, and the content part of BlogHolder shows up, but the list of BlogEntries (in this case 1) does not.

This is a fresh install of the blog module. I haven't changed a thing. Am I missing a flag or something?

Avatar
Willr

Forum Moderator, 5513 Posts

24 July 2010 at 11:14pm

The blog holder in the tree on the left doesn't have a little plus icon next to it does it? Are you logged in as the admin user?

Avatar
prawnstar

Community Member, 127 Posts

25 July 2010 at 12:29pm

cdeangelus,

Silly question...but...did you set up your blog by following these instructions: [url]http://doc.silverstripe.org/modules:blog:installation[/url]?

And now when you refresh you only see your default Page.ss?

Being a newcomer to SS, I had the same issue until I discovered that the rest of the instructions should tell you to then go set up your /themes/blackcandy_blog themes. (Assuming you are using blackcandy, otherwise you'll edit /themes/yourtheme_blog.)

Basically you need to create your BlogEntry.ss and BlogHolder.ss templates to display the blog on your site. Copy the code from:
/blog/templates/layout/BlogHolder.ss
/blog/templates/layout/BlogEntry.ss

and put that code inside your newly created templates where you want the blog entries to show up:
/themes/blackcandy/templates/BlogHolder.ss
/themes/blackcandy/templates/BlogEntry.ss

(note those paths)

Good luck,
Chris.b