Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

How to set up the Blog Module?


Reply


8 Posts   2795 Views

Avatar
xichael

Community Member, 5 Posts

27 November 2010 at 8:34am

Edited: 27/11/2010 11:01am

Is there a step by step tutorial on how to set up the Blog Module; something like the [url=http://doc.silverstripe.org/tutorial:1-building-a-basic-site]tutorial:1-building-a-basic-site[/url] tutorial? I'm just starting out, trying to convert a static HTML/CSS website to a SilverStripe template. Thanks to that tutorial, I've got the site working for the most part, but I can't find any comparable guidance on how to setup a blog page.

Help!

Avatar
xichael

Community Member, 5 Posts

3 December 2010 at 8:08am

I'd still love to get some help here...

Avatar
cruzer45

Community Member, 9 Posts

3 December 2010 at 11:25am

Edited: 03/12/2010 11:38am

Same Here
------------------------------
EDIT
___________________________________

LOL sorry guys didn't notice there was a README in the archive.

For the rest of us.... the instructions are here

[url]http://doc.silverstripe.org/modules:blog:installation[/url]

Have a good one!

Avatar
xichael

Community Member, 5 Posts

31 December 2010 at 11:20pm

Edited: 31/12/2010 11:21pm

I saw that, but it didn't get me very far... Perhaps someone could expand the article?... Is that really all that's out there?

Avatar
Invader_Zim

Community Member, 141 Posts

1 January 2011 at 1:48am

It would be helpful if you can post what's going wrong, or where you get stuck.

Installing a blog is usually like installing any other module...

  • Download the blog-module, unpack it locally on your hard drive, rename it to "blog"
  • Upload the blog directory to the root of your silverstripe installation, you'll now have directories like "cms", "mysite", "sapphire" and "blog"...
  • Log in to your silverstripe-backend and visit [url]http://yoursite/dev/build/?flush=1[/url]; that will build the database entries for your blog and create some dummy entries.
  • In your SiteTree there should be a new BlogHolder with a BlogEntry now
  • Profit :-)

Notice: it might be helpful to put your site into "developer mode" before you start, to see any proper error messages.
Just add this to your /mysite/_config.php: Director::set_environment_type('dev');

Must get ready for some serious partying tonight :-)

Cheers,
Christian

Avatar
markb

Community Member, 1 Post

18 March 2011 at 6:33pm

Ok.I understand this thread. I have install all components (under 2hr!) I have a basic site up and running.
I have even downloaded a new "Theme" with a blog type skin.....but where is the actual "blog-module"???

Thanks
Mark

Avatar
fengdeadshot

Community Member, 6 Posts

12 April 2011 at 12:20am

markb, just to let you know,
to get modules, such as the "blog module" got to the top nav bar here, click on the "Extensions" tab,
Then click on modules, after that, type in blog, its the first one to come up, use that to install a blog module.

Avatar
bigstack

Community Member, 2 Posts

9 May 2011 at 3:11pm

Edited: 09/05/2011 3:11pm

when you click on the link to go to this mythical "blog how to "

it takes you to a page that has nothing there ... it is like someone removed the how to.
it only has a link to "sapphire"