Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[Solved] Any workaround for fixing blog entry formatting on non-blog entry pages?


Reply

511 Views

Avatar
prawnstar

2 February 2011 at 9:06am (Last edited: 14 March 2011 9:09am), Community Member, 116 Posts

EDIT:
Elegant solution found here http://silverstripe.org/general-questions/show/13388#post298731

- - -

Just wondering if anyone has a creative way to fix the issue of using the blog module and displaying blog entries on another page, like the home page? I realize tutorial 2 covers how to display articles on another page, but in practice tutorial 2 doesn't actually work with the blog module.

The issue, if you don't know what I mean, is this:
http://open.silverstripe.org/ticket/5535

There has to be a creative and easy work around without hacking the core as this post suggests:
http://silverstripe.org/general-questions/show/13388

Possibly extending the blog entry page class and making that the home page?

I know I can't be the only person here with this issue. I've implemented 5 sites in the past year using SS and every client has asked for this functionality and every time I have to explain that they can have that functionality, but they can't use any formatting in the first paragraph. That's generally been a negative conversation, overall. I'd like to find a non-hack workaround for this if possible.

The funny thing is, SilverStripe's own site is plagued by this behavior. See attached screenshot of search results from the forum(which I assume is run with the blog module?).

Chris.b

Attached Files