Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Tags are not listed on Blog Summary page


Reply


648 Views

Avatar
speedengineer

Community Member, 4 Posts

9 March 2011 at 12:43am

Edited: 09/03/2011 12:49am

Hi there,

For some reason, the tags for my blog do not show up on the blog summary page, but they do show up just fine on the actual blog page. See the example photos below:

Tags are not listed on the summary page:

Tags are correctly displayed on the actual blog entry page:

A few weeks ago I explored this problem in the templates folder of the blog module, specifically BlogEntry.ss and BlogSummary.ss. Each file contains the following code to display the tags, respectively:

<p class="tags">
   <% _t('TAGS', 'Tags:') %>
   <% control TagsCollection %>
      <a href="$Link" title="<% _t('VIEWALLPOSTTAGGED', 'View all posts tagged') %> '$Tag'" rel="tag">$Tag</a><% if Last %><% else %>,<% end_if %>
   <% end_control %>
</p>

<p class="tags">
   Tags:
   <% control TagsCollection %>
      <a href="$Link" title="View all posts tagged '$Tag'" rel="tag">$Tag</a><% if Last %><% else %>,<% end_if %>
   <% end_control %>
</p>

I tried using the "a href" line from BlogEntry.ss in place of the same line in BlogSummary.ss just to see if it made a difference, but still nothing showed up.

Has anyone else had an issue with this, or know of how I can fix it? I am new to CMS and Silverstripe, so any help would be greatly appreciated. Thanks!